Ntp rrd neg values on graph?


  • LAYER 8 Global Moderator

    So noticed that the ntp graph was not showing any neg values.  So I reset all the rrd data and now showing neg values for say offset.  But still not showing any value for freq.

    Now I saw there was a bug report about neg offset that shows resolved long time ago
    https://redmine.pfsense.org/issues/4423

    I thinking clearing my data fixed my offset not showing neg since it currently now is..  But freq seems to be 0.00, which from when I look at rv via ntpq is currently showing neg value.  See attached.




  • Seeing similar results here.

    V 2.3.1_5, simple NTP,no attached GPS serial.
    NTP Logging wasn't enabled, turned it on @08:08:16.
    Logs show NTP sync up, activity.
    Command prompt check of ntpq shows ntp activity, freq. data.
    Graph results at 08:25 (1Hr - 1min res) shows all 0.00 for freq (and wander).

    Looks somewhat buggish at the moment.


  • LAYER 8 Global Moderator

    ok thanks - so just not something messed up with mine ;)  My wander is currently positive so couldn't check on that.. But yeah neg on freq doesn't seem to graph..



  • After ~7.5 Hrs, Wander shows up and -ve's plot for offset at least.
    Still no freq data tho.

    Something ugly this way comes…...



  • LAYER 8 Global Moderator

    is your freq data neg?  Take a look via ntpq on pfsense and do a rv



  • Yes, the last three "Spot checks" (about the times of my posts) I did via shell show Freq values of -82.402, -81.666, and -81.930.
    As I mentioned the Offset data has -ve values and they seem to record/plot properly.

    I'd guess an issue with the recording of Freq data.
    Do you want to redmine this one?


  • LAYER 8 Global Moderator

    yeah prob going to have to..

    Posted to redmine
    https://redmine.pfsense.org/issues/6503



  • Simply take the patch mentioned in the redmine bug 4423 for offset, and apply the same idea to frequency:

    --- rrd.inc.old 2016-07-01 16:29:15.917333000 -0400
    +++ rrd.inc     2016-07-01 16:23:52.048739000 -0400
    @@ -912,7 +912,7 @@
                                    $rrdcreate .= "DS:sjit:GAUGE:$ntpdvalid:0:1000 ";
                                    $rrdcreate .= "DS:cjit:GAUGE:$ntpdvalid:0:1000 ";
                                    $rrdcreate .= "DS:wander:GAUGE:$ntpdvalid:0:1000 ";
    -                               $rrdcreate .= "DS:freq:GAUGE:$ntpdvalid:0:1000 ";
    +                               $rrdcreate .= "DS:freq:GAUGE:$ntpdvalid:-1000:1000 ";
                                    $rrdcreate .= "DS:disp:GAUGE:$ntpdvalid:0:1000 ";
                                    $rrdcreate .= "RRA:MIN:0.5:1:1200 ";
                                    $rrdcreate .= "RRA:MIN:0.5:5:720 ";
    
    

    Works for me; but as before you have to rm /var/db/rrd/ntpd.rrd and then recreate it (In services/ntp/settings, uncheck rrd logging, save, then check rrd logging, save).

    But, with typical negative frequency values, this will screw up the graph scaling terribly, so this is probably not the best solution with the current graphing back-end.


Log in to reply