Add webGUI cert to squid trusted CA



  • Hello,

    I added the squid service to pfsense. Squid is working as an https proxy. The webGUI is using an self signed certificate. So then I try to access the webGUI the squid proxy can't validate the cert and rejects the request. How can I add the webGUI cert to the trusted CA store from squid?

    Thanks



  • Hi,

    I would suggest to activate the option in squid WebUI:

    "Bypass Proxy for Private Address Destination"

    If you are running pfsense in TRANPARENT mode, then you have another possibility to add the IP addresses in "bypass proxy for these destionation IPs" you want squid to bypass.
    Or if you are running squid in NON-TRANSPARENT mode then you can enable this in your clients browsers, which address to bypass OR when you are running it with WPAD then add there the IP addresses you want to bypass the proxy.

    In all cases make sure there are firewall rules to access the WebUI with the port it needs.

    Regards.



  • Thanks

    "Bypass Proxy for Private Address Destination" did the job