Problem only with OVPN 2.1 rc9, anyone else?


  • I have a Road Warrior tunnel setup on my pfSense box.

    Everything works fine under 2.1 rc7 and rc8 but once I upgrade to rc9 I get the following error.

    TLS Error: TLS key negotiation failed to occur within 60 seconds (check your network connectivity)

    Reverting back to 2.1 rc7 or rc8 gets my VPN back up and running.  Obviously it cant be my settings and must be some problem within rc9 but googling it doesnt seem to be happening to anyone else using OVPN and wondered if maybe it might be some kind of conflict with OVPN within pfSense.

    Just wondering if anyone else using pfSense has this problem? I am using pfSense 1.2.1 RC1 from Aug. 4th.

    If anyone else can confirm or deny this problem I'll post up my config files and hopefully figure out whether this is a pfSense issue, a 1.2.1 RC1 issue, OVPN issue, or just my own setup.

    Thanks in advance for any help.


  • I am getting the same error, and was convinced I did the configuration wrong but it I followed the guide to a tee.  Please let me know if you find a fix!


  • Thanks Kev, try using the older release openvpn-2.1_rc7 with your same configuration and see if you successfully complete initialization.  Its at the bottom of the following link:

    http://openvpn.net/release/

    Or even openvpn-2.1_rc8 from this link if you use Windows:

    https://secure.openvpn.net/beta/openvpn-2.1_rc8-install.exe

    Those 2 versions still work for me while rc9 does not.