Need some help with the dns forwarder and dns resolver, using torguard openvpn



  • Hi!

    i have installed and configured torguard in my pfsense router, it works pretty good most of the time, but i have some problem with all of the internet access on both the openvpn and regular non encrypted connection, it sometimes just freezes and i need to restart my modem to get it all to work again.

    so to my questions, i can start with under the system menu, and general setup, i have entered the 2 different dns of torguard in 2 of fields, but do i need to change the Use Gateway to torguard there, or can it be set to none, or is 2 dns adresses enought or could i use even more?

    and my other question is the dns forwarder in the sevice menu, this is set to enable dns forwarder, but nothing else on this page is entered or choosen, should it be so?

    and the last question is the dns resolver, this one is not enabled, should it be? if so what sould be enabled?

    as you can se i am a total newbie about this, i have done some testing years ago but i have forgotten most of it.

    im looking forward to your help.

    thanks.



  • Anyone?



  • Hi,

    Sorry, I can't help you at this time. But maybe you can help me!

    I am new to pfSense and also have Torguard VPN.  I have successfully installed Torguard on DD-WRT and ASUS Merlin Build routers.  I am trying to get it to work on pfSense 2.3.2.

    I followed the instructions on https://torguard.net/knowledgebase.php?action=displayarticle&id=208.

    The wan, lan and Torguard VPN interfaces are up and running. My laptop gets an IP address, but I can't access any websites.

    What instructions did you use to install TorGuard VPN?

    Thanks in advance for the help.

    EDIT: I was able to fix the problem. I started creating screen shots to send to support. When I landed on the LAN Interface page, I noticed that IPv6 Configuration Type was set to “Track Interface”. I don’t use IPv6 and recall seeing on the pfsense forum that IPv6 needed to be turned off.  I tried to change it to “None”.  But I received a message that DHCPv6 Server was active and must be disabled first.  So, I went to Services, DHCPv6 Server & RA, and set it to disable.  I then went to Interfaces. LAN, IPv6 Configuration Type = “None”.  I am now able to access websites.  Problem solved!


Log in to reply