Captive portal is enabled and everyone got internet



  • hi,

    Just recently upgraded to 2.1.3 and I restore my xml backup one by one just to make sure everything will work fine. However i run into an issue on captive portal.

    My captive portal is enabled however even the users who is not in the mac list/ip allowed list they can still access the internet. Does someone experience this.

    Also, i notice the portal port has been change to 16000.  Can someone help also as the login page to input the voucher or username is not showing up. I am sitll using the default portal page. DID i miss something on the configuration ?



  • @m4st3rc1p0:

    Just recently upgraded to 2.1.3 and I restore my xml backup one by one just to make sure everything will work fine. However i run into an issue on captive portal.
    My captive portal is enabled however even the users who is not in the mac list/ip allowed list they can still access the internet. Does someone experience this.

    Never.
    If you want to have someone explaining this, he'll be needing your setup - physical and config. Please, do not omit the smallest non-default thing.

    @m4st3rc1p0:

    Also, i notice the portal port has been change to 16000.  …

    Well, again : you config seems very hosed to me.
    Backup your config.xml, extract whatever is between <captiveportal>and</captiveportal> and post it to http://pastebin.org - link here.



  • thanks, for the reply. I setup a new box and install 2.3.1. restore  the following configuration dhcp, rules and captive portal after setting up the 3 interface.

    • WAN

    • LAN

    • LAN2

    after restoring i notice on the mac list, all listed mac does not have any actions assign, so what i did is edit manually 1 by 1 all the listed and give them the proper access which pass.

    When i try to view the page on portal it redirects on me https://pfsense15:16000/index.ph?allowedzone.

    My backup xml file came from version 2.1.5 and my configuration is I am using a hyper-v 2012 r2 .



  • I advise you to 'destroy' your captive portal setup - remove the zone completely and redo it.

    True, in theory you could import a very ancient ancient config file - but …. better be save : don't (IMHO).

    The captive portal will work with 99 % of all settings on 'default'.
    As soon as it is up, add your won settings by hand one by one.

    The fact that you have a port like "16000" seems very awkward to me.



  • hi,

    I followed what you said and it worked the port change back to 8002, but when i try to access the interface where i define the portal should be working i was prompted with a white screen no error or whatsoever , the only interface the portal screen work in on WAN. I did not select WAN interface to be part of the portal.

    Can someone enlighten me on this.



  • Read and check this https://doc.pfsense.org/index.php/Captive_Portal_Troubleshooting

    Is the nginx running on the portal interface ?
    Use SSH acces and :
    ps ax | grep 'nginx'
    sockstat -4l | grep 'nginx'

    Btw : being able to access the portal on the WAN NIC ….. well, something is very wrong.


Log in to reply