Cannot delete or update squid package



  • Hi,

    I tried to update my squid package to the latest version. Unfortunately it gives me always this output after 1-2 seconds:

    
    >>> Upgrading pfSense-pkg-squid... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be UPGRADED:
    	pfSense-pkg-squid: 0.4.16_2 -> 0.4.18 [pfSense]
    
    53 KiB to be downloaded.
    Fetching pfSense-pkg-squid-0.4.18.txz: ...... done
    Checking integrity... done (0 conflicting)
    [1/1] Upgrading pfSense-pkg-squid from 0.4.16_2 to 0.4.18...
    Removing squid components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    [1/1] Extracting pfSense-pkg-squid-0.4.18: .......... done
    Saving updated package information...
    overwrite!
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...done.
    Executing custom_php_resync_config_command()...done.
    Menu items... done.
    Services... done.
    Writing configuration... done.
    Message from pfSense-pkg-squid-0.4.18:
    Please visit Services - Squid Proxy Server menu to configure the package and enable the proxy.
    >>> Cleaning up cache... done.
    Success
    
    

    The same is happening when I try to uninstall the package:

    
    >>> Upgrading pfSense-pkg-squid... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    The following 1 package(s) will be affected (of 0 checked):
    
    Installed packages to be UPGRADED:
    	pfSense-pkg-squid: 0.4.16_2 -> 0.4.18 [pfSense]
    
    53 KiB to be downloaded.
    Fetching pfSense-pkg-squid-0.4.18.txz: ...... done
    Checking integrity... done (0 conflicting)
    [1/1] Upgrading pfSense-pkg-squid from 0.4.16_2 to 0.4.18...
    Removing squid components...
    Menu items... done.
    Services... done.
    Loading package instructions...
    [1/1] Extracting pfSense-pkg-squid-0.4.18: .......... done
    Saving updated package information...
    overwrite!
    Loading package configuration... done.
    Configuring package components...
    Loading package instructions...
    Custom commands...
    Executing custom_php_install_command()...done.
    Executing custom_php_resync_config_command()...done.
    Menu items... done.
    Services... done.
    Writing configuration... done.
    Message from pfSense-pkg-squid-0.4.18:
    Please visit Services - Squid Proxy Server menu to configure the package and enable the proxy.
    >>> Cleaning up cache... done.
    Success
    
    

    I had in mind that there was an option "clear package lock" or something like that - but I cannot found it. So I would appreciate any kind of help :-)

    Regards



  • Okay, a reboot fixed this issue but I think a reboot should be the last opinion.

    Regards


Log in to reply