Squid, itv hub & roku 3



  • I've recently set up pfsense for the first time and, so far, it seems like a really good solution for me.

    There is, however, one slightly odd problem - ITV hub doesn't work on my roku 3 and only on my roku if squid is enabled.

    It works perfectly well if I disable squid and it also works on my tablet without difficulty. I've tried tweaking a few of the settings, but I can't find anything that fixes it - except disabling squid, which isn't an option as I'm using squid guard for filtering on my network.

    I have tried having squid without squid guard enabled, in case it was the latter causing the problem, but it didn't help.

    Any ideas or suggestions for what to try or look into would be gratefully received!

    Edit: One of the things I tried was allowing the ip for itv.com (based on what dig told me it was) through the proxy altogether, but that didn't seem to help.  It's possible, of course, that it's using a different url/ip but I'm not sure how to figure that out.


Log in to reply