Proxy startet nicht bzw. funktioniert nicht wirklich



  • Hallo Leute,

    ich würde gerne bei meinem Firewall den Proxy-Server einmal zum laufen bekommen und im Anschluss dann konfigurieren.
    Leider komme ich aber nicht so ganz damit klar.

    Ich habe folgende Pakete dazu installier:

    • squid

    • squidGuard

    • Lightsquid

    Fehlt da vielleicht noch etwas, was ich vielleicht noch zusätzlich installieren müsste?

    Wenn ich auf "Services->Squid Proxy Server" gehe und dort bei "General" den Proxy aktivieren möchte, bekomme ich folgende Fehlermeldung:

    The following input errors were detected:

    • SSL interception cannot be enabled without a CA.

    Wie müsste ich da am besten vorgehen?

    Ich habe bei den "Package Manager" unter "Available Packages" noch diese Pakete entdeckt:

    • haproxy

    • haproxy-devil

    • siproxd

    • zabbix-proxy

    Müsste ich vielleicht damit etwas einstellen?

    Bitte um Hilfe.

    Mit freundlichen Grüßen
    Daniel



  • Hallo Leute,

    gibt es niemanden der mir hierbei helfen könnte?
    Ich bekomme das nicht ganz hin und sitze schon ziemlich lange daran.

    Bitte um Hilfe.

    Mit freundlichen Grüßen
    Daniel



  • den Proxy nicht für SSL aktivieren oder eben ein Zertifikat ( CA ) anlegen.



  • Hallo Anfänger,

    ach so okay und wie lege ich ein Zertifikat an?

    MfG
    Daniel



  • Hallo Leute,

    kann mir jemand hier nicht helfen?
    Ich komme echt nicht weiter.

    Ich habe nun diesen Zertifikat erstellt und nun bekomme ich die "pfSense"-Maske im Browser nicht mehr öffnen.
    Wie kann ich das nun rückgängig machen?

    Bitte um Hilfe!

    Mit freundlichen Grüßen
    Daniel

    PS:
    Gibt es für pfSense keine vernünftige Dokumentation, wo man gewisse grundlegenden Sachen erklärt bekommt?



  • https://turbofuture.com/internet/Intercepting-HTTPS-Traffic-Using-the-Squid-Proxy-in-pfSense

    Mit der Goldsubscription bekommst Du ein fettes Buch/Guide von rund 700 Seiten dazu.
    Ansonsten ist das Wiki, Forum und google Dein Freund.

    Unter der o.g. URL steht genau beschrieben, wie man HTTPS mit Squid bei der pfSense filtern kann.



  • Hallo Exordium,

    danke für deine Unterstützung.
    Ich werde mir gerne die 700 Seiten Doku anschauen und hoffe das ich damit weiter komme.

    Zum Stand der Dinge:
    Über die Kommandoebene habe ich "Restore recent configuration" benutzt und den Firewall damit um paar Tage zurück gesetzt.
    Nun bekomme ich über dem Browser wieder die Maske zusehen.

    Gruß
    Daniel



  • @Exordium:

    https://turbofuture.com/internet/Intercepting-HTTPS-Traffic-Using-the-Squid-Proxy-in-pfSense

    Mit der Goldsubscription bekommst Du ein fettes Buch/Guide von rund 700 Seiten dazu.
    Ansonsten ist das Wiki, Forum und google Dein Freund.

    Unter der o.g. URL steht genau beschrieben, wie man HTTPS mit Squid bei der pfSense filtern kann.

    Hallo Exordium,

    habe mir die oben vorgeschlagene Seite angeschaut und stoße direkt schon am Anfang auf einem gravierenden Problem.

    Auf "Step 1" steht das ich das Paket "Squid3" installieren soll.
    Wenn ich nun auf "System \ Package Manager" gehe habe ich dort das Problem, dass dieses Paket auf meinem Firewall nicht vorhanden ist.
    Wie installiere ich nun das Paket?

    Gibt es nirgendswo eine einheitliche Dokumentation für meinen Firewall-Version (2.3.1)?
    Genau deshalb komme ich auch nicht weiter. Denn auf jede Internetseite wird irgendwas vorgegaukelt aber nichts davon führt zum tatsächlichen Ziel. Forste schon seit ca. 1 Woche lang sämtliche Internetseiten um das Problem zu lösen. Habe etliche Seiten besucht und mir sogar Videos bei YouTube angeschaut. Es kann doch nicht sein, dass die "pfSense"-Erfinder so armselig sind und keine vernünftige Doku raus bringen oder? Ich bin echt am verzweifeln, ehrlich.

    Bitte um Hilfe.

    Gruß
    Daniel



  • Schau mal unter den Packages, bzw. installierten Packages. Der Squid sollte dort eine Version von 3.5.x haben. Das ist mit Squid/3 gemeint. Ich vermute, man hatte in einer älteren pfSense Version mal die Möglichkeit zwischen Squid 2 und Squid 3 auszuwählen und das ist noch ein Relikt aus dieser Zeit. Das normale Squid-Paket installieren und Du hast V3 drauf. Bin leider auch noch nicht so lange bei der pfSense dabei und musste mir einiges zusammensuchen. Allerdings solltest Du schon gewisse Grundkenntnisse mitbringen. Eine fehlkonfigurierte Firewall kann sich schnell der restlichen Welt öffnen… :-)



  • @Exordium:

    Schau mal unter den Packages, bzw. installierten Packages.

    Habe ich bereits aber ist nicht vorhanden. Siehe Bild die ich hier angehängt habe. Falls diese richtig ist, dann wäre ich auf eine Antwort sehr dankbar.

    @Exordium:

    Der Squid sollte dort eine Version von 3.5.x haben. Das ist mit Squid/3 gemeint. Ich vermute, man hatte in einer älteren pfSense Version mal die Möglichkeit zwischen Squid 2 und Squid 3 auszuwählen und das ist noch ein Relikt aus dieser Zeit.

    Leider auch nicht gegeben. Denn das normale Squid ist bei mir auf 0.4.21.
    Es gibt einen Lightsquid der Version 3.0.4 ist, aber wie der Name hier schon verrät ist dieses was anderes und abgespecktes.

    @Exordium:

    Das normale Squid-Paket installieren und Du hast V3 drauf. Bin leider auch noch nicht so lange bei der pfSense dabei und musste mir einiges zusammensuchen.

    Ja echt traurig, dass "pfSense" keine vernünftige Doku zu seinem eigenen Produkt anbietet.
    Man muss hier alles aus den Fingern ziehen und tüfteln.
    Das ist echt Nervtötend.
    Leider mache ich auch diese negativen Erfahrung.

    @Exordium:

    Allerdings solltest Du schon gewisse Grundkenntnisse mitbringen. Eine fehlkonfigurierte Firewall kann sich schnell der restlichen Welt öffnen… :-)

    Gewisse Grundkenntnisse sind definitive vorhanden allerdings reicht das nicht aus, wenn man die Software nicht kennt und es nirgendswo beschrieben ist.

    Wir alle sollten mal bei den Betreiber/Entwicklern einen massiven Beschwerde einreichen.

    Gruß
    Daniel

    PS:
    Es ist schon sehr lächerlich, dass die Software in Portugiesische Sprache gibt aber leider nicht in Deutsch.
    Dabei wird es in Deutschland extrem benutzt.




  • Meine Güte… Der Squid in der aktuellen Version von pfSense hat doch 3.5.x (Ich meine NICHT die Package-Version!) Schau doch mal bei den Squid Package-Depencies. Sieht man sogar in Deinem Screenshot die Squid-Version.

    Wenn Dir Englisch nicht reicht, kannst Du gerne ein Projekt starten, welche sich um eine deutsche Translation kümmert. Wir reden hier von OpenSource, die nix kostet und in die viele freiwillig Zeit investieren. Wenn das hier zu komplex, kompliziert oder nervtötend ist, musst Du eben auf etwas anderes umsteigen. Z.B gibt es für die Heimfirewall auch "ipfire" - ganz in Deutsch.



  • @Crashbreaker:

    …Wir alle sollten mal bei den Betreiber/Entwicklern einen massiven Beschwerde einreichen.
    ...
    Es ist schon sehr lächerlich, dass die Software in Portugiesische Sprache gibt aber leider nicht in Deutsch.
    Dabei wird es in Deutschland extrem benutzt.

    Kauf Dir was Kommerzielles, da kannst Du Support fordern! Mit Deinem Anspruchsdenken bist Du hier nicht sonderlich gut aufgehoben.

    -teddy



  • Naja…so was  :o

    Meine beide Vorgänger haben bereits geschrieben.....

    Sei doch positiver und bisschen Geduld, vielleicht bekommst dann Hilfe....
    Es gibt im Deutsche Bereich hier einige sehr hilfreiche Personen so wie ich das mitbekomme, also ich wurde schreiben, gehe etwas positiver an die Sache dran.



  • Moin,

    @Pippin: So habe ich das "damals" auch gehalten, hatte geringe Vorkenntnisse aus meiner Fli4L Phase und war sonst ein Noob.
    Inzwischen sehe ich mich als Noob mit Grundkenntnissen. mit ein wenig Initiative kann man hier einiges an Wissen mitnehmen…

    -teddy


  • Moderator

    Gibt es für pfSense keine vernünftige Dokumentation, wo man gewisse grundlegenden Sachen erklärt bekommt?

    Doch, doc.pfsense.org bspw. ist ein guter Anfang den man auch selbst noch erweitern kann. Zusätzlich gibt es wie die Kollegen hier schon sagen bspw. via Gold Subscription, die mit 99$ pro JAHR nun auch kein wahnsinnig großer Posten ist, die Möglichkeit den aktuellen Draft zum pfSense Buch einzusehen, auch als online Fassung.

    Grundsätzlich scheint aber noch nicht ganz bei den Leuten - nicht dem Threadstarter im Spezifischen - aber noch nicht angekommen zu sein, dass bspw. Zusatzpakete wie Squid und Co. nicht direkt vom pfSense Core Team betreut werden und KEIN direkter Bestandteil der Distribution sind. Da muss man dann eben ggf. ein wenig mehr Ressourcen reinstecken und sich informieren. Einige Dinge hätte man aber durchaus einfach selbst erarbeiten können. Was eine CA ist und was Squid damit meint bspw. wäre nicht so schwer gewesen zu googeln. Auch die Verwirrung mit Squid3 kann ich teils nachvollziehen, wenn aber direkt in der Paketbeschreibung des installierten Pakets steht, dass es sich um Squid 3.5.x handelt, sollte doch klar sein, dass das Paket schon installiert ist.

    Ich habe das Forum als gute Austauschplattform von Wissen kennen gelernt, aber an mancher Stelle muss auch ein wenig Eigeninitiative kommen, denn das hier ist trotz allem kein offizielles Ticketsystem, bei dem einfach Anfragen mit "mach mal" gestellt werden können ;)

    Viele Grüße



  • Hallo Leute,

    danke für die vielen Antworten.
    Teilweise habt ihr recht aber ich werde um das hier zu kürzen direkt zum Thema kommen.

    Dank der obigen Link konnte ich mein Problem doch noch lösen.
    Proxy mit SSL, also mit Zertifikat-Erstellung gelöst.

    Aber mir kommt da doch noch eine Frage und hoffe das ihr mir die beantworten könnt.
    Und zwar, um den Test mit SSL machen zu können, habe ich die Internetseite "reddit.com" besucht, so wie es auch auf der obigen Seite vorgeschlagen wurde. Damit konnte ich sehen, dass mein Zertifikat über dem Proxy übernommen wurde.

    Allerdings wird mir in der Adresszeile ein Fehler aufgezeigt, wenn ich mein pfSense-Konfigurationsmaske im Browser über SSL aufrufe.
    Da wird ein Fehler angezeigt. Siehe bitte Bild die ich hier mit anhängen werde.

    Gruß
    Daniel



  • Moderator

    Natürlich wird das angemängelt. Weil du das Default Cert der pfSense nicht ersetzt hast. Das ist ein selbst generiertes Zertifikat (self signed) was natürlich keinerlei Gültigkeit in den Browsern hat. Warum auch. Entweder man installiert es sich, dass es nicht mehr angemängelt wird oder man kauft/erstellt sich ein offizielles das von einer sauberen CA signiert wurde.



  • Hallo JeGr,

    bitte erkläre mir das genauer.
    Wenn ich das Default Cert mit dem von mir ersetze, dann kann ich die pfSense-Maske im Browser nicht mehr öffnen.
    Wie müsste ich dann vor gehen?

    Exportiert und anschließend installiert habe ich diesen CA.
    Wie müsste ich da das machen um diesen Fehler zu beheben?

    Bitte um Erläuterung.

    Gruß
    Daniel



  • @JeGr:

    Gibt es für pfSense keine vernünftige Dokumentation, wo man gewisse grundlegenden Sachen erklärt bekommt?

    Doch, doc.pfsense.org bspw. ist ein guter Anfang den man auch selbst noch erweitern kann.

    Mit der Doku Seite komme ich überhaupt nicht klar.
    Wie funktioniert das und wo kann ich mich da bzgl meinen Problemen durchforsten?

    Bitte um Hilfe.

    MfG
    Daniel



  • Moin,

    @Crashbreaker:

    Mit der Doku Seite komme ich überhaupt nicht klar.
    Wie funktioniert das und wo kann ich mich da bzgl meinen Problemen durchforsten?

    Bitte um Hilfe.

    Entweder du zeigst Eigeninitiative und gibst das hier zu erkennen oder Du suchst die einen Dienstleister der das ganze für €€ einrichtet.
    Anfangen könntest Du mit aussagekräftigen Beschreibungen deines Fehlers. Welcher Browser, welche Fehlermeldung?

    -teddy



  • @magicteddy:

    Moin,

    @Crashbreaker:

    Mit der Doku Seite komme ich überhaupt nicht klar.
    Wie funktioniert das und wo kann ich mich da bzgl meinen Problemen durchforsten?

    Bitte um Hilfe.

    Entweder du zeigst Eigeninitiative und gibst das hier zu erkennen oder Du suchst die einen Dienstleister der das ganze für €€ einrichtet.
    Anfangen könntest Du mit aussagekräftigen Beschreibungen deines Fehlers. Welcher Browser, welche Fehlermeldung?

    -teddy

    Sag mal liest du überhaupt die Beiträge bevor du hier deinen destruktiven Senf abgibst?
    Die Eigeninitiative zeige ich wohl hier sehr deutlich genug, in dem ich meine Probleme im größten Teil bisher selbst lösen konnte, auch wenn es etwas langsamer verläuft als bei manchen es der Fall ist.
    Oder hast du hier in irgendeinem Thread eine ausführliche Beschreibung zur Lösung des Problems gelesen? Sicherlich nicht, weil dann wäre ich mit dem Kapitel hier fertig.

    Zu deiner super klugen Frage:
    Mit dieser Frage bestätigst du mir, dass du hier überhaupt nichts verstanden hast worum es hier geht, da du nichts gelesen hast.
    Denn anhand den vielen Screenshots allein schon hättest du die Fragen wie: "welchen Browser ich nutze" und "um welche Fehlermeldung es geht" echt ersparen können. Hinzu kommt ja meine vielen Beiträge die das nochmal ausführlich erklären.

    Echt dumm! Hauptsache hier destruktiv einen Kommentar schreiben. Wahrscheinlich bist du nur heiß drauf um deinen Beitrags counter hoch zu puschen um bei den anderen besser zu wirken.
    Solltest echt mal deine aggressiven und destruktive Einstellung hier komplett sein lassen. Denn dieser Forum dient zur gegenseitige Unterstützung.

    Ich bat hier die Erfahrenen Forum Nutzer um konstruktive Unterstützung und nichts anderes.
    Wenn du nichts konstruktives beisteuern kannst, dann erspare dir bitte hier und überall im Forum deinen lächerlichen Kommentare.
    Denn du müllst damit die Datenbanken unnötig und raubst allen Lesern die Zeit, weil sie deinen Beitrag lesen.

    Danke!


  • Moderator

    @Crashbreaker: Bitte mal halblang. Ein anderes Forenmitglied hier zu beleidigen, nur weil der Ton vielleicht mal ein wenig direkter wird, ist unnötig und selbst destruktiv. Damit machst du es nicht gerade einfacher dir helfen zu wollen. Zumal deine Screenshots auch nur die Hälfte so wirklich anzeigen was gefragt wurde. Außerdem zeigt dein Screenshot nur ein Zertifikat, keine CA o.ä.

    Um das ganze sinnvoll deinem Browser beizubringen müsstest du eine eigene CA erstellen.

    • create internal CA
    • sinnvolle Werte rein
    • CA certificate exportieren (nicht den Key) und im Browser als CA importieren und vertrauen
    • certificate
    • create internal certificate
    • obige CA auswählen und cert erstellen
    • common name MUSS der Name sein, mit dem die pfSense aufgerufen wird (pfsense.domain.lan bspw.)
    • ggf. mit alternative names noch weitere hinzufügen wenns mehrere namen gibt
    • das erstellen und dem webconfigurator zuweisen

    Das in Kürze, weil zwischen zwei Terminen.



  • @JeGr:

    @Crashbreaker: Bitte mal halblang. Ein anderes Forenmitglied hier zu beleidigen, nur weil der Ton vielleicht mal ein wenig direkter wird, ist unnötig und selbst destruktiv. Damit machst du es nicht gerade einfacher dir helfen zu wollen. Zumal deine Screenshots auch nur die Hälfte so wirklich anzeigen was gefragt wurde. Außerdem zeigt dein Screenshot nur ein Zertifikat, keine CA o.ä.

    Solche Mitglieder gehören nicht hier her und man braucht jetzt seine aggressives Handeln auch nicht runter spielen.
    Ich bin hier am verzweifeln und suche daher eine Lösung und gebe mir ohne Ende mühe um es euch so einfach wie möglich zu machen etc..
    Hätte ich das so hier gehandhabt wie er, hätte ich bestimmt mir wer weiß was anhören müssen …

    Als leihe weiß ich auch nicht genau, was ihr an Information braucht. Da bisher nichts konkretes rüber kommt.
    Ja weil ich ein CA bereits erstellt habe, die ja auch soweit funktioniert hat. Aber trotz dessen (siehe Screenshot) wird diese Fehler angezeigt was ich mir nicht erklären kann.

    @JeGr:

    Um das ganze sinnvoll deinem Browser beizubringen müsstest du eine eigene CA erstellen.

    • create internal CA
    • sinnvolle Werte rein
    • CA certificate exportieren (nicht den Key) und im Browser als CA importieren und vertrauen
    • certificate
    • create internal certificate
    • obige CA auswählen und cert erstellen
    • common name MUSS der Name sein, mit dem die pfSense aufgerufen wird (pfsense.domain.lan bspw.)
    • ggf. mit alternative names noch weitere hinzufügen wenns mehrere namen gibt
    • das erstellen und dem webconfigurator zuweisen

    Das in Kürze, weil zwischen zwei Terminen.

    All das habe ich bereits, laut der Beschreibung 1:1 von dieser Seite hier (https://turbofuture.com/internet/Intercepting-HTTPS-Traffic-Using-the-Squid-Proxy-in-pfSense) erstellt.

    Nun ist es so, dass ich plötzlich das Problem habe, dass die Proxy / CA usw. ohne SSL Verschlüsselung funktioniert.
    Mit SSL werden die Seiten gar nicht angezeigt. Da kommt dann diese Standard Err_Nochwas ..
    Aber bis vor kurzem lief es auch mit SSL. Leider habe ich so viel nun an den ganzen Einstellungen rumgespielt, dass ich nicht mehr weiß, woran es nun liegt.

    Um das Problem einzukesseln, sagt mir bitte was ihr an Information braucht.
    Weil ich kann ja schlecht hier unzählige Screenshots auf Schätzungsbasis machen.

    Die ganze Zeit tüftel ich blind einfach so dahin und da das ganze so viele Parametereinstellungen hat, sitze ich bestimmt bis Weihnachten noch dran. Da wie gesagt nirgendswo eine vernünftige Doku für gibt.

    Wie habt ihr es bei euch gelöst, hat da jemand vielleicht seine eigene Vorgehensweise?

    MfG
    Daniel



  • Leute bitte hilft mir.
    Ich bin echt am verzweifeln. Sitze ungelogen seit Tagen dran und bekomme das nicht hin.

    Proxy mit CA läuft aber ohne SSL.
    Sobald ich SSL aktiviere, dann kann ich keine Internetseiten mehr aufrufen.
    Woran liegt das?

    Ich stelle euch ein Screenshot von der Internetseite zur Verfügung.

    MfG
    Daniel




  • Guten Morgen,

    gibt es hier niemand der mir helfen kann?
    Bitte um Hilfe.

    MfG
    Daniel


  • Moderator

    Ich möchte nochmals am Rande darauf hinweisen, dass das Forum durchweg aus freiwilliger Hilfeleistung Leuten in ihrer Freizeit besteht. Wenn man alle paar Stunden seinen eigenen Thread pusht bringt es wenig, wenn die Leute schlichtweg keine ZEIT haben, sich mit deinem Problem zu beschäftigen. Das hier ist NICHT der offizielle (bezahlte) pfSense Support, der dir mit Reaktionszeit zur Verfügung steht. Und auch kein Partner Support. Und auch wenn man vielleicht möchte, hat man eben nicht immer und jederzeit und innerhalb von x Stunden Zeit um jede mögliche Problemstellung zu beheben. Insofern solltest du dir deine Kritik, die du an Teddy so direkt rausgehauen hast, vielleicht einmal selbst nochmal durchlesen, was du von anderen Leuten hier erwartest.

    Und bevor es wieder heißt, es wäre hier mieser Support und man würde Neulingen nicht helfen etc. drekct.: Das kann ich wenn man die letzten 100-200 Topics betrachtet nicht bestätigen. Aber es hängt auch davon ab, wie eine Anfrage gestellt wird und wie derjenige damit umgeht. Dass sich bei deinem Topic hier vielleicht nicht viele noch positiv angesprochen fühlen dir zu helfen, kann ich leider ebenso nachvollziehen. Leider mangelt es mir gerade selbst massiv an Zeit, große Zeit hier im Forum zu verbringen, wenn man bei der Arbeit schon genug Probleme hat (oder auch schlicht in Urlaub ist! Es ist schließlich Sommerferienzeit, bitte mal nicht vergessen!)

    Gruß



  • Hallo JeGr,

    mir ist es völlig bewusst, dass hier jede Hilfe auf eine freiwillige Basis beruht. Ich beschäftige mich schon einige Jahrzehnte mit Forums und weiß wie alles vonstatten geht. Ich habe hier niemanden dazu verdonnert mir eine Lösung auf Reaktionszeit bzgl. meines Problems zu liefern oder Äußerungen getätigt, womit ich bestimmte Support Leistungen beanspruchen wollen würde. Ich habe nur lediglich eine (neutrale) Frage gestellt und die Frage war sogar soweit harmlos, dass ich nur gefragt habe: "ob es jemanden gibt der mir helfen könnte?". Nicht mehr und nicht weniger. Das besagt aber nicht, dass ich durch "Support-Wahnvorstellungen" jemanden dazu verpflichtet habe mir hier unbedingt zu helfen. Ich bin nur auf jede Hilfe sehr dankbar.

    Daher brauche ich mein Kritik, der ja mit recht an "teddy" ging, nicht selbst durchlesen. Alles was ich kritisiere geht selbstverständlich auch an mich selbst!
    Mir ist es bewusst, dass viele auch im Leben noch zig andere wichtige Dinge zu tun haben. Unter anderem, dass viele von euch auch Berufstätig sind - ich ja ebenfalls - und hier nur in seiner Freizeit online sein können und somit nicht direkt jederzeit zur Verfügung stehen. Man sollte die Kirche auch im Dorf lassen ;) .

    Mir ging es nur darum, dass vielen die Lösungen meist parat haben und hier diese nur nennen (eventuell vielleicht auch sogar Schritt für Schritt) die Vorgehensweise erklären / schildern könnten.
    Denn Standardmäßig konfiguriert man ja solche Funktionen so gut wie immer (fast) gleich. Ich denke, dass vielen all diese Anfängerfehler durchaus bekannt sind, da ihr reichlich Erfahrungen bereits gesammelt habt. Daher ist es für euch viel leichter mir zu helfen.

    Ich denke für den Thread den du verfasst hast, müsstest du reichlich viel Zeit in Anspruch genommen haben. Sowas ist echt unproduktiv, denn du erwähnst ja selbst, dass du kaum Zeit hast und verfasst etwas unbrauchbares. Statt dessen hättest du mir doch einen nützlichen Tipp geben können. Davon hätten wir dann beide was von. So könntest du auch dein Wissen und Erfahrung uns allen repräsentiert.
    Daher mein Stichwort: –- KONSTRUKTIV WERDEN --- nicht destruktiv !!!
    Als Moderator fungierst du sogar als Vorbild.

    Gruß


  • Moderator

    Ich denke für den Thread den du verfasst hast, müsstest du reichlich viel Zeit in Anspruch genommen haben. Sowas ist echt unproduktiv, denn du erwähnst ja selbst, dass du kaum Zeit hast und verfasst etwas unbrauchbares.

    Du irrst. Der kleine Absatz hat mich jetzt keine 10min gekostet. Genau deshalb, wie du so schön sagst, weil ich Moderator bin habe ich nochmals freundlich erwähnt - und das nicht nur wegen dir sondern generell - dass das hier freiwillig etc. ist. Und Ferien.  Und Urlaub. Und trotzdem du jedes Mal behauptest, dass du das ja alles weißt und berücksichtigst schreibst du alle paar Stunden in denen keiner antwortet einen Push und fragst nach, hakst nach, schiebst dein Thema etc. Schreibst wie verzweifelt du bist etc. Wenn es so dringend ist, würde ich raten dich eben an einen Partner oder pfSense selbst zu wenden. Das kostet, aber dir wird gleich geholfen. Aber hier immer wieder die Leute zu belehren - und so lesen sich einige deiner Antworten eben völlig neutral betrachtet - bringt niemandem was und den Leuten die es lesen weniger Lust hier ihre Zeit zu investieren.

    Zu deinem Kommentar oder der Kritik an mir: Hätte ich zu all deinen Fragen eine Antwort gehabt, hätte ich die sicher in aller Kürze zumindest gepostet und ggf. später weiter eruiert. Dein CA Problem habe ich genauso angegangen. Leider verstehe ich aber deine Ausführungen mit "das geht alles nicht" siehe Screenshots leider nicht, denn in den Screens sehe ich kein "geht nicht". Zudem kann ich in meiner möglichst neutral gehaltenen Antwort nun wirklich nichts destruktives finden und nur weil dir der kurze Kommentar von anderen nicht gefallen hat, habe ich da keinen Anteil dran.

    Zum Problem:
    Wenn dein CA Kram noch nicht funktioniert könntest du einmal damit anfangen auch dafür sinnvolle Screen/Details zu posten. Du hast also selbst eine CA erstellt -> sieht man nirgends. Dein eigenes Cert mit dem dann die WebUI nicht funktioniert? -> zeigen.
    Erstellung bitte zeigen, Import im Browser zeigen, dass nicht das Cert sondern die CA im Browser korrekt importiert und beglaubigt wurde.

    Das sind alles Dinge, die keiner hier zum Helfen sieht, du behauptest korrekt gemacht zu haben aber nicht funktionieren. Dann beginne doch bitte einfach damit, die Sachen auch zu posten. Das wäre sehr hilfreich in der Fehlerbehebung.

    Gruß



  • @ Crashbreacker

    Du sollstest Dich erstmal über Zertifikate schlau machen, dann kommst Du selber drauf wie das läuft.

    Kurz zur Info :

    • Du hast ein selbst signiertes Zertifikat erstellt, das mängelt der Browser als unsicher an ( je nach Sicherheitseinstellungen ), diese Zertifikate kann der User als vetrauenswürdig akzeptieren, dann wird die Seite geladen ( bei Deinem Screenshot von der Seite auf Erweitert klicken ).
    • wenn Du ein von einer öffentlichen CA signiertes Zertifikat einbindest bemängelt das der Browser nicht.
      ABER :
    • wenn Du im CP auf HTTPS setzt und ein User startet seinen Browser mit einer HTTPS-Seite ( z.B. google nutzt https ), dann wird die Seite ja auf Deine https-CP-Seite umgeleitet und dafür ist weder ein selbst signiertes noch von einer öffentlichen CA signiertes Zertifikat gültig, so dass IMMER ein Zertifikatsfehler angezeigt wird. Richtig umgeleitet wird, wenn der User mit einer http-Seite startet.
    • wenn Du im CP die Option "Disable HTTPS Forwards" aktivierst funktioniert der Aufruf der CP-Seite von einer HTTPS-Seite aus gar nicht ( Browser Fehler wird angezeigt ).

    Hinzu kommt noch der leidige Fehler seit 2.3.1 mit nginx, der bei Webkonfigurator-Einstellung https nicht auf die Squidguard-Fehlerseiten umleitet.

    Im übrigen wäre ich froh, wenn ich auf meine Fragen hier im Forum nur annähernd soviel Feedback bekommen würde wie Du ( aber die sind wahrscheinlich zu speziell ).

    Gruss