Squidaguard no muestra Sgerror.php



  • El problema que tengo es que no se porqué motivo, el squidguard actua correctamente, dispara el bloqueo y a la hora de mostrar el sgerror.php…..
    En google Chrome me lo descarga y en IE me muestra el código.

    Tanto en los grupos ACL como en Common ACL, he puesto el Recirect mode en "int error page(enter error mesage)". También he probado dejarlo configurado al redirect solo en Common ACL, y dejando los grupos en "none"

    • Tengo instalado la versión 2.3.1-RELEASE-p5 con webGui en https. El modo transparente está desactivado y lo manejo con WPAD siguiendo las guias y script de javcasta.
    • Versión de Squid: 0.4.21
    • Versiób de SquidGuard 1.14_3

    Desde ya, muchas gracias



  • Alguna idea? a alquien le paso algo similar?



  • A mí me pasa algo similar.
    Yo activo el squid en transparent mode, pongo en ACL lo que deseo bloquear, y en vez de mostrar la página de bloqueo típica que genera squid, me sale es una pantalla de conexión denegada.



  • Hola

    @javcasta:

    Hola

    El código de /usr/local/www/nginx-dist/my-no-autorizado.html

    http://wpad.localdomain.local/my-no-autorizado.htmlhttp://wpad.TUDOMINIO.ALGO/my-no-autorizado.html )

    
    <title>Error</title>
    
    # FORBIDDEN.
    
    ACCESO DENEGADO
    
    PONGASE EN CONTACTO CON SU ADMDOR DE RED SI LO CONSIDERA NECESARIO.
    
    [admin@undominio.com](mailto:admin@lundominio.com).
    
    

    Al correr WPAD en una instancia para HTTP (NO HTTPS) en el dir /usr/local/www/nginx-dist/ , no tiene definido PhP, y no puede ejecutar php. Así que cuando squidGuard redirige a HTTP (NO HTTPS) un fichero php no se ejecutará se descargará.

    Así que mi solución  es definir en squidGuard usar una redirección a una página de contenido estático (html) ante error o prohibición:

    Common ACL >
    Redirect mode >
    ext url move (enter URL) >

    http://wpad.localdomain.local/my-no-autorizado.html

    Salu2

    Y otra posible solución

    @javcasta:

    Hola

    En este hilo del foro en Portugues:

    Página de erro do SquidGuard customizada | Nova instancia NGINX (suporte PHP)

    muestran como lanzar una nueva instancia de nginx con soporte PhP para la página de error de squidGuard

    https://forum.pfsense.org/index.php?topic=115653.0

    No lo he probado, pero pinta bastante bien :)

    Salu2

    Salu2



  • Gracias Javier, ya había leido dicho post y no lograba hacerlo funcionar, creo que ahora está funcionando al haber tildado la opción y al aplicar las soluciones propuestas de levantar otra instacia de nginx y php en el puerto 80.

    WebGUI redirect* (Disable webConfigurator redirect rule)



  • Ahora se ve que busca ejecturar el php, pero me da error de permisos

    connect() to unix:/var/run/php-fpm.socket failed (13: Permission denied) while connecting to upstream, client: 127.0.0.1,…............



  • Hola

    En el foro en Portugues he visto esto referente a tu tema:

    https://forum.pfsense.org/index.php?topic=115653.0

    Salu2



  • al parecer, quedó funcionando ahora.

    agregué la siguiente linea en /usr/local/etc/nginx/nginx.conf

    user  root wheel;

    Para finalizar y por si te sirve Javier, te paso como quedó el archivo nginx.conf para que una instacia nueva de nginx pueda trabajar con php, sobre una wgui en https y con WPAD.

    
    user  root wheel;
    worker_processes  2;
    events {
        worker_connections  1024;
    }
    http {
        include       mime.types;
    
        default_type  application/octet-stream;
        log_format main ' -  [] ""   "" "" ""';
        sendfile        on;
    
        keepalive_timeout  65;
    
        server {
            listen      <ip del="" servidor="">:80;
            server_name  wpad.<mi dominio="">;
    
            root   /usr/local/www/nginx-dist;
    
            error_page  404               /50x.html;
            access_log  /var/log/nginx/access.log  main;
            # redirect server error pages to the static page /50x.html
            error_page   500 502 503 504  /50x.html;
            location = /50x.html {
                root   /usr/local/www/nginx-dist;
            }
            location ~ \.php$ {
                    try_files $uri =404;
                    fastcgi_pass    unix:/var/run/php-fpm.socket;
                    fastcgi_index   index.php;
                    fastcgi_param  SCRIPT_FILENAME  $document_root$fastcgi_script_name;
                    fastcgi_read_timeout    180;
                    include         /usr/local/etc/nginx/fastcgi_params;
    
            }
        }
    }</mi></ip> 
    


  • Hola

    Gracias por la info. de la conf de nginx para que trabaje con php la instancia para wpad :)

    Salu2