FTP Error - econnrefused - connection refused by server



  • Hi there,

    I am using multiple WAN connections (WAN1 and WAN2). Every thing is working fine but FTP wont work well.
    No solutions worked so far.

    If i connect to my FTP server, my FTP server responds and connects correct. First it shows the listing of folder and then disconnect me after some time or when i navigate to subfolders. I tried with multiple FTP Software and Filezila show this Error:

    Status:      Resolving address of ftp.mydomain.de
    Status:      Connecting to 81.xxx.xxx.xxx:21
    Status:      Connection established, waiting for welcome message...
    Status:      Server does not support non-ASCII characters.
    Status:      Logged in
    Status:      Retrieving directory listing...
    Command: PWD
    Response: 257 "/" is current directory.
    Command: TYPE I
    Response: 200 Using BINARY mode to transfer data.
    Command: PASV
    Response: 227 Entering Passive Mode (81,169,145,47,189,96)
    Command: MLSD
    Error:        The data connection could not be established: ECONNREFUSED - Connection refused by server
    Response: 150 Opening ASCII mode data connection.

    Firewall Rules are:
    Protocol    Source              Port    Destination    Port    Gateway

    Ipv4          LAN1 / LAN2      any    any              21      WAN1 (also tried WAN1_and_WAN2)

    Does anyone know what i can do to fix this?...  :-\

    Thanks
    David