2.3.1 amd64 installer iso fails to boot on esxi 6.0u2



  • I'm having a problem installing on a new esxi server. The strange thing is I have other esxi servers with same setup and pfsense installs fine from the same iso and exact same VM configuration.

    I get a " can't load 'kernel' " error from the last stage of the freebsd bootloader as seen here: http://i.imgur.com/wj4rSjt.png

    I took an album of screenshots here that show directory listing of /boot and /boot/kernel directories on the iso: http://imgur.com/a/oV34r
    I'm not familiar with pfsense bootloader process, is it supposed to ungzip the kernel.gz before trying to load?

    I've tried multiple vm configurations: IDE, SCSI and SATA CD-ROM drive, different disk controllers for the virtual hard disk to no avail.

    I'm about to try the 32bit installer w/ a 32bit VM.

    Anyone have other ideas?



  • What's the config for the VM?  Can we assume you're using the FreeBSD (64-bit) profile?



  • @KOM:

    What's the config for the VM?  Can we assume you're using the FreeBSD (64-bit) profile?

    Yes using that profile. I've also tried the Other->Other profile just to try it.

    Hardware-wise I've tried probably a dozen combos of CPU cores, RAM, NICs, SCSI, SATA, SAS adapters for both virtual disks and the cd-rom drive.

    I just uploaded 32-bit installer ISO and will try that next.

    Thanks for any ideas.



  • It's likely having issues reading the ISO at the ESX level for some reason would be my best guess. Don't bother with 32 bit, that's a dead end and should never be used on 64 bit systems.



  • Here is what I get on the 32-bit installer iso:
    http://i.imgur.com/Pu5EcPZ.png

    Also I just uploaded the 64bit ISO again so I'll give that a try.

    I had originally scp'd the 64bit ISO directly from a working ESXI 6.0 to the new one. I'll compare md5sum just to confirm.



  • Thanks for pointing me in the right direction. The pfsense ISO's were corrupted on upload. It took me about 8 tries from more than a few different machines to get on to upload and have the same sha hash. I'm not sure what's causing it because other ISO's have uploaded without problems.