ESXi 6.0 U2 + Virtual Appliance + VMXNet3 NICS > 4 = Breaks LAN Interface



  • When I deploy the latest version of the Virtual Appliance in VMWare ESXi +Vsphere Server and add 3 additional interfaces using VMXNet3 NICS, the LAN interface will not communicate. It will not respond to a ping from another device, nor will it get a ping reply from a device using pfSense diagnostics ping. Of course the Web interface is not accessible either. The WAN interface works with no problems. If the 5th VMXNet3 interface is removed, the LAN interface works as expected and all is well. This problem drove me crazy all day today as I've been learning PFSense and VMWare the last couple months, quite successfully, but I always think that it's something I'm doing wrong when things don't go right.

    If the additional NICs are E1000e, the problem does not occur. I tried VMXNet2s, but PFSense does not detect these interfaces.

    I need a total of 7 interfaces, so I used 4 VMXNet3s & 7 E1000es' and the LAN interface is OK with that combination. Add an additional VMXNet3 & it breaks?

    It took me a good part of the day to figure this out and tried all types of combinations. I'll know better tomorrow if there are any other problems with the combination that now appears to work. Unfortunately I have to sort between my learning curve & real problems.

    Any feedback on this would be greatly appreciated. Or if someone else could test, that would be great!

    Thanks in advance for any help.





  • @cmb:

    ESX changes the order in that case.
    https://forum.pfsense.org/index.php?topic=107937.msg601285#msg601285

    Thanks for the fast response CMB! Greatly appreciated!

    I'll look at this tomorrow.

    Sorry I posted in the wrong Subject, didn't see the one about Virtualization. Maybe you can move it there?

    Thanks and I'll let you know what I find.



  • cmb,

    I verified your information tonight in my home lab. The NICs do in fact get reordered and alternate between the 1st "4" and additional NICs after 4.

    vmx0 = vnic1
    vmx1 = vnic5
    vmx2 = vnic2
    vmx3 = vnic6
    vmx4 = vnic3
    vmx5 = vnic7
    vmx6 = vnic4

    This wasted much time today, but it took me a while to realize it was the 5th NIC screwing me up. Previously I've been using 4 NICs and it always worked. Now I fresh install and configure with 7 interfaces, & had no idea what was going on.

    Should of searched the forum 1st, but my head was spinning and really didn't know what to search for. I was always used to the pfSense vmx order matching the VM. Now I know.

    Thanks again for your help and sorry for repeating a newbie question.



  • I can confirm this problem. Also drove me nuts for a couple hours. C'est la vie

    Thanks in advance

    Piers

    pfSense 2.3.2 (from 2.3.1 OVA)
    ESXi 6.0.0 Build 3620759
    HPE BL460c G6


Log in to reply