Hyper-V and pfsense keeps losing connection

  • Hi all.
    I recently started using pfSense, and so far loving it… Except for one little thing, it randomly looses connection.
    But first a little background on my setup, i'm running Windows Server 2012 R2 on a HP DL380p Gen8 and using the onboard HP Ethernet 1Gb 4-port 331FLR Adapter, mapped one port as LAN in virtual switch and another port as WAN in another virtual switch.

    I have then installed pfSense with the quick/easy option and set things up accordingly.
    Then it works flawlessly with full throughput on my 500/500 fiber.

    But then all of the sudden maybe after a day or two it drops connection on both interfaces as far as i can tell, so i'm unable to access the web config.
    But if i access the Hyper-V terminal of the pfSense vm then i can access all the menus.
    Then i have to either reinstall the pfSense or choose the "reset to factory settings".

    Does anybody have a suggestion on what to try next.
    I have tried the 2.3.1 image and upgraded to p5, and i have looked at all the hyper-v logs i could find without any luck.
    I'm going to try the daily build of 2.3.2 later today, but i don't think it will solve my problem.

    So again, any suggestions will be highly appreciated :-)

  • Okay, i may have found the issue, though it should be solved in a driver update, but the issues seems to be the same i'm experiencing.
    It relates to VMQ on networkcards.

    Here is the article i found about it: http://www.aidanfinn.com/?p=16876

    I will let you know if it solves my problem.

Log in to reply