Captive portal - DHCP not giving an address - SOLVED



  • Hello to all

    Firstly, a big thank you for all the effort put into the forum and tutorials - bravo!

    I've serached but can't find a response to my question - so here goes;

    Running pfSense as a firewall and want to add the captive portal for my WiFi users. I've connected the access point to the OPT1 interface, cut the DHCP and given him the address: 192.168.2.10

    Router: xx.xx.xxx.241    WAN on pfSense: xx.xx.xxx.246     LAN: 192.168.0.253      OPT1: 192.168.2.1
                                     Rules: Block private networks       Rules: Pass LAN            Rules: PASS OPT1
                                                                                            "Any" protocol              "Any" protocol
                                                                                   Source: LAN subset       Source: "Any"   
                                                                                   Dest:    ANY                 Dest: NOT LAN
                                                                                                                     subset
    DHCP Enabled on OPT1, Captive portal on OPT1 with local user manager enabled.
    All gateway settings default.

    When I connect, via a wifi laptop, to the access point, I don't get an address from the DHCP server.
    I'm a bit stuck, as I can't test any other potential connection problems before getting an address. ???

    Anyone have any ideas please?

    Many thanks in advance



  • Is your access point configured as bridge?
    If it's configured as router it wont work :)



  • Thank you for the tip - it's a Linksys WAP54G configured as an 'Access point'…



  • I dont really know this device.
    At first glance it seems to be a router.
    A router wont work.

    Can you look at your manuals to find out if it is able to work as a bridge?
    –> The RJ45-connector has to be bridged to the WLAN.



  • It can be used as a bridge, but it would seem that in Bridging mode it will only 'speak' to other Linksys wireless access points.

    I don't know if this screenshot is of any use, but it seems to be the only options I have…

    It's not something to do with the firewall settings? I only ask as I can't seem to get my head around what to let thru which interface etc....



  • Connect a laptop to the wireless. If the address you get from DHCP is a different range than the address given by pfSense then it is being routed. If the address given by DHCP is the same as given out by pfSense then it is bridged.



  • Thanks for your help - when I 'connected' the laptop (via WiFi) to the access point, given that the pfSense DHCP wouldn't assign an address I simply got an address on 169.XXX.XXX.XXX 255.255.0.0 - this was with the access point in 'access point' mode.

    Seems strange that a fairly simple access point creates such a problem - which is why I asked about my firewall settings - it just seemed to me that the demand for an address wasn't actually getting to the correct interface….



  • Many thanks for the input, but as I tentatively suggested the other day, in fact the problem was caused by my firewall rules - I was blocking too much!


Log in to reply