PfSense 2.3.1release "community edition" stuck beacon issues



  • I can't seem to explain things without this turning into several paragraphs, but I'll do my best.
    Mid-June this year I installed PfSense 2.3.1-RELEASE-p5 (amd64) on my old dual core AMD machine. With the old WRT54G router as AP everything ran fine with only my phone using WiFi. There is only 1 other hotspot near me which uses channel 1 so I had the Linksys on channel 9. A few days ago I added a TP-Link TL-WN881ND ver 1.1 with Atheros AR9287 chipset. Once I got it working I unplugged the AP and things seemed to be working fine with my phone easily seeing the internet. When I discovered how tricky setting up WLAN/LAN bridging is, I left them un-bridged.
    After about a day (22-26 hours) the WiFi dropped completely, not visible and my phone disconnected. It would show back up but my phone couldn't get an IP address. Plugged the AP back in and the phone could connect to the internet, but after a few minutes even that would disappear. Both WLANs would show up but only the AP would let my phone connect for a few minutes before both SSIDs would vanish again. In the web GUI the TP-Link would show "up" and have the IP I assigned, but the CLI screen was full of stuck beacon (bmiss count 4) errors. I looked around online and changed a couple settings which seemed to make things work again. Of course another ~ 24 hours later it was dropping and coming back again. I tried another config change which caused the whole machine to reboot and again all good for another 24 or so hours with the TP-Link working great, the AP unplugged and my phone happy with WiFi. Today it's back to the intermittent shenanigans again, so I rebooted the machine and while that did not correct the PCIe card problems the AP has stayed up all day.
    Since a lot of the other postings I've found about this seemed to be after various upgrades and sometimes going back to an earlier "snap" fixed things but I'm on a fresh PfSense installation I should make a fresh post.
    I hate how long this is and I know people hate reading long posts but I didn't know any other way to present a fairly clear picture of how I got where I am at this point.
    This morning when both SSIDs were going out and in, I rebooted the machine via the WebGui but all that did was make the Linksys AP stay online all day. The WLAN pops in and out and won't let the phone have an IP. I don't want to change anything else with the wireless card until I have a better idea of what is causing this.

    Having typed all that up and hoping I've presented a clear picture of the current state of things, what else can I do at this point? I really want this to work but considering all the different info I've found so far about the stuck beacon issue, I've resigned myself to the idea I might have to keep using an external AP for awhile. Any help would be appreciated.



  • This morning I went through my settings compared to a setup tutorial and found I had missed setting up a firewall rule allowing traffic to pass over ath0_wlan0, and soon as I applied the rule my phone connected right away with good internet traffic. I'll see how things go. I've seen plenty of other forum posts here and elsewhere suggesting that as long as the WLAN doesn't continue to drop, I may have to put up with the stuck beacon warnings.



  • Well, that worked for a few hours. I napped for about 3 hours and woke up to the dropping situation again, where the WLAN would vanish and my phone would connect to the AP, then it would vanish too half a minute later. AP would come back and phone connects, then WLAN comes back but can't connect. Both go away again for a bit, then the cycle starts all over. Turned on the console monitor and this time some new lines in addition to the stuck beacon (which always have bmiss count 4 if that means anything):

    ath0:ath_tx_default_comp: bf 0xfffffe000097bd48: seqno 2037: bf_next_not_NULL!
    ath0:ath_tx_default_comp: bf 0xfffffe000097cba0: seqno 2038: bf_next_not_NULL!

    several lines of that with the last 4 digits of the 0xffff part changing and the seqno advancing each line.

    Apparently the recent ath_tx_default lines mean some problem with drivers for Atheros based cards, so at least I have a better direction to look in. For the moment I've disabled the WLAN and I'll just keep the AP going while I investigate further or until I get a response with some help.


  • LAYER 8 Netgate

    I've resigned myself to the idea I might have to keep using an external AP for awhile. Any help would be appreciated.

    Unfortunately, due to the state of the wireless adapter drivers in FreeBSD, you will probably always have a more satisfying wireless experience using external APs.



  • Get a UniFi AP AC Lite.



  • Couldn't find a UniFi device in my price range but found a Cisco WAP4410N on Craigslist for $15 which is working great. The guy even threw in a 2nd one!


Log in to reply