PfSense + Apache



  • Всем привет!
    Друзья, помогите плз с настройкой.
    Стоит pfSense, за ним сервак с Apache + Adobe Media Server. Нужно пробросить 80 порт для HTTP сервера.
    В Firewall > NAT > создано правило:

    После этого из WAN доступ к Apache работает, а по локалке нет. Что не так?



  • Он и не будет работать из коробки, смотрите в сторону NAT Reflection.



  • Доброе
    1. Смените порт веб-фейса пф на что-то отличное от 80-го.

    2

    Он и не будет работать из коробки, смотрите в сторону NAT Reflection.

    Вместо этого я бы исп. split dns. Т.е. "заставил" бы думать ваш локальный dns-сервер, что ваш Апач живет в лок. сети.

    Если у вас не много машин, то просто добавьте сопоставление имя -> ип-адрес в файл hosts на ваших лок. машинах.
    После сбросьте днс-кэш или перезагр. машины.



  • 1. Смените порт веб-фейса пф на что-то отличное от 80-го.

    Начиная с не помню какой версии это делать необязательно, если не открыт порт TCP 80 на WAN к WEBgui, чего в 99,99% быть не должно.
    По крайней мере в 2.2.6 в этом точно нет необходимости.



  • Парни,
    вообщем ситуация такая pfSense у меня на порту 9080 из чего я сделал вывод, что 80 не занят им.
    И самое главное, если я из LAN обращаюсь к серваку на Apache, т.е. 192.168.1.100 - все ок, все медиа-потоки с Adobe Media Server через локальный IP идут все ок. Но у нас сделана переадресация с домена на наш WAN IP. И при обращении к серверу через домен, т.е. на его WAN IP ничего не открывается. Верится мне, что проблема полная ерунда, т.к. на другом pfSense все ок было..
    А что конкретно смотреть в NAT Reflection ??



  • Поставил только чекбокс Enable automatic outbound NAT for Reflection и все заработало :) Непонятно только, какое правило pfSense добавил, т.к. нового ничего не обнаружил.



  • @alvian:

    Поставил только чекбокс Enable automatic outbound NAT for Reflection и все заработало :) Непонятно только, какое правило pfSense добавил, т.к. нового ничего не обнаружил.

    Зайдите браузером по адресу
    http://%pfsense_IP%/status.php

    (http://%pfsense_IP%:9080/status.php)

    Увидите все настройки\правила\состояние pfsense
    Поиском поищите PFREFLECT, reflect, reflection



  • @alvian:

    Поставил только чекбокс Enable automatic outbound NAT for Reflection и все заработало :) Непонятно только, какое правило pfSense добавил, т.к. нового ничего не обнаружил.

    Правила можно посмотреть через консоль pfctl -sr и pfctl -sn
    А правило простое — NAT from LAN-net to apache-server:port



  • Ребят, спасибо всем ! Оч выручили!


Log in to reply