ERROR Installing squid and squidGuard in pfsense 2.3.2



  • Hi All,

    I am getting below error when i am going to install squid and squidGuard pakage

    Installing pfSense-pkg-squidGuard…
    Updating pfSense-core repository catalogue…
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue…
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking integrity… done (0 conflicting)
    The following 3 package(s) will be affected (of 0 checked):

    New packages to be INSTALLED:
    pfSense-pkg-squidGuard: 1.14_3 [pfSense]
    squidGuard: 1.4_15 [pfSense]
    squid: 3.5.19_1 [pfSense]

    Number of packages to be installed: 3

    The process will require 10 MiB more space.
    [1/3] Installing squid-3.5.19_1…
    ===> Creating groups.
    Using existing group ‘squid’.
    ===> Creating users
    Using existing user ‘squid’.
    install: not found
    pkg: PRE-INSTALL script failed
    Failed



  • That’s the issue here.
    https://redmine.pfsense.org/issues/6643

    To work around it, run:

    tar xv -C / -f /usr/local/share/pfSense/base.txz ./usr/bin/install
    


  • Thanks cmb,

    Now its working.


 

© Copyright 2002 - 2018 Rubicon Communications, LLC | Privacy Policy