VMWare Offline Gateway for WAN Interface



  • Hello,
    I have quite strange issue with pfsense. I installed it a few days ago and it worked fine. I have two interfaces WAN and NAT. since yesterday I have no internet access in my NAT. I checked Web Console and notice that Gateway is offline.
    Pfsense is connected to two networks: VM and NAT. On VM Network I have additionally VCenter Server (134.46.220.12) and ESX Host (134.46.220.13).
    Pfsense WAN interface was configured with (134.46.220.11). Default Gateway (134.46.220.1). I can ping DG from .13 and .12 but cannot from pfsense.
    Both .13 and .12 have internet.

    Any idea what can be wrong?



  • Hmm the description of your setup is confusing, first things to check are:

    1. login on your pfsense web gui
    2. Go to -> Diagnostics -> Edit File
    3. On the "Edit File" page click "Browse" and go to /conf/ and select "config.xml" then press "load"
    4. Now press F3 or CTRL+F and search for "<gateways>"
    5. In your scenario you should have only one block that should look like this:

    <gateways><gateway_item><interface>wan</interface>
    <gateway>your.gateway.ip.address</gateway>
    <name>GW_WAN</name>
    <weight>1</weight>
    <ipprotocol>inet</ipprotocol>
    <interval><defaultgw></defaultgw></interval></gateway_item></gateways>

    6. If you have more than one "<gateway_item>" (but need only one GW), keep the one with "<name>GW_WAN</name>", make sure the IP address matches the Default Gateway IP address and delete the others.
    7. Reboot your pfsense
    8. After the reboot go to -> Interfaces -> WAN, check the "IPv4 Upstream Gateway", if you have "None" click the down arrow on the right, you should have only " GW_WAN_your.gateway.ip.address" select it then click "Save", you should have your default gateway back online

    That's the only thing to check on pfSense if you have problems with your gateway. The rest is a matter of connectivity (network cable unplugged, virtual nic deactivated, etc…)</gateway_item></gateways>



  • Hello,
    Thanks for response. This is my GW part of XML file:

    <gateways><gateway_item><interface>wan</interface>
            <gateway>134.46.220.1</gateway>
            <name>GW_WAN</name>
            <weight>1</weight>
            <ipprotocol>inet</ipprotocol>
            <interval><defaultgw></defaultgw></interval></gateway_item></gateways>

    After reboot GW is Offline.
    In network 134.46.220.0 I have additionally ESX Host and VCenter. Both have internet and can ping Default Gateway. I cannot reach Gateway only from pfsense and it worked before for a few days. Occasionally I have issue with VCenter and ESX Host (they are not pingable) but ESX Host reboot always fixes this issue. Unfortunately not for pfsense…
    Do you think it can be some blocking from Gateway?

    Do you think it can be issue with gateway?



  • Could be anything,

    Show us your ESXi networking configuration. How many standard vswitches, which physical nic is assigned to those switches, etc.:

    –-----------------------------------------------------------------------------------------------------------------------------
    Standard Switch: vSwitch0 Physical Adapters
    Virtual Machine Port Group vmnicX 1000 Full
    vSwitchName
    virtual machines connected to this switch

    Do that please for each vSwitch you have configured so that I can have a better idea of your setup. I'd like to see how you plugged your VMs. Confirm that all virtual machines connected to their respective vSwitches have the little icon with a green right arrow next to their name. And provide us with the Subnet Mask for each of the IP addresses you have assigned to your systems.

    In any case that thing you said about your other VMs losing connectivity from time to time and needing a reboot of your esxi doesn't sound good. Usually networking works or works not, intermittent connectivity is definitively not good.

    The basic network configuration for an esxi with pfsense as a firewall usually looks like this:

    Internet <-> WANnic_ Router_LANnic <-> esxi physical_nic1 assigned to vSwitch0 with only pfsense_WAN virtual nic connected to this vSwitch

    and

    esxi physical_nic2 assigned to vSwitch1 with pfsense_LAN virtual nic and other VMs connected to this vSwitch. If you don't have a second physical nic vSwitch1 can be created without physical nic and VMs inside this network will need to go through pfsense in order to access the Internet.

    Sorry if your setup already looks like this but I need to have a better idea of how you configured your esxi networking.



  • Ok Problem was fixed. It was port issue. Only 2 connections were allowed.