Ntopng install error on 2.3



  • Hey folks

    I am getting the following when I attempt to install the latest ntop package on 2.3:

    
    >>> Installing pfSense-pkg-ntopng... 
    Updating pfSense-core repository catalogue...
    pfSense-core repository is up-to-date.
    Updating pfSense repository catalogue...
    pfSense repository is up-to-date.
    All repositories are up-to-date.
    Checking integrity... done (0 conflicting)
    The following 6 package(s) will be affected (of 0 checked):
    
    New packages to be INSTALLED:
    	pfSense-pkg-ntopng: 0.8.4 [pfSense]
    	ntopng: 2.2.2016.05.28 [pfSense]
    	GeoIP: 1.6.9 [pfSense]
    	graphviz: 2.38.0_12 [pfSense]
    	redis: 3.0.7 [pfSense]
    	gdbm: 1.12 [pfSense]
    
    Number of packages to be installed: 6
    
    The process will require 74 MiB more space.
    [1/6] Installing ntopng-2.2.2016.05.28...
    ===> Creating groups.
    Using existing group 'ntopng'.
    ===> Creating users
    Using existing user 'ntopng'.
    [1/6] Extracting ntopng-2.2.2016.05.28: .....
    pkg: Fail to create /usr/local/share/ntopng/scripts/callbacks: No such file or directory
    [1/6] Extracting ntopng-2.2.2016.05.28... done
    Failed
    
    

    This box was running 2.2.x and I did have ntopng installed on it. I was under the impression that 2.3 removed any incompatible packages prior to upgrade but it appears that there were some remnants left behind that are causing it grief. What would be the best way to get ntopng to install on my box? It is running:

    
    2.3.2-RELEASE (amd64)
    built on Tue Jul 19 12:44:43 CDT 2016
    FreeBSD 10.3-RELEASE-p5
    
    

    Thanks.


  • Rebel Alliance Developer Netgate

    rm -rf /usr/local/share/ntopng/
    

    And then try again



  • That did the trick. Thanks.


Log in to reply