PFsense NO se actualiza [SOLUCIONADO]



  • Buenas mis estimados, mi tema es que en diferentes sitios tengo PFsense aprovisionado, funcionando de maravilla pero he notado que el tema de las actualizaciones dejo de estar disponible.

    Como ven el mensajes es común sin importar la versión (Unable to check for updates)

    Agradezco infinitamente si me dan una pista de que tengo mal y que debo hacer para ver de nuevo las actualizaciones y los paquetes








  • Hola

    Ref: pfSense 2-3-X - Fixing a Broken pkg Database https://doc.pfsense.org/index.php/Fixing_a_Broken_pkg_Database

    In some rare edge cases it is possible for the pkg database in /var/db/pkg/ to become corrupted. In the unlikely event this happens to a firewall, it can usually be corrected by running a few commands to re-create the database.

    Note that the following commands only account for the base system of a typical CE full installation.

    Ensure that the package database directory exists:

    /bin/mkdir -p /var/db/pkg/ /root/var/db/pkg/

    Force an update of the package repository data:

    /usr/sbin/pkg update -f

    Force a reinstall of the pfSense base package and kernel:

    /usr/sbin/pkg install -yf pkg pfSense pfSense-kernel-pfSense

    Refresh the php.ini and extensions.ini to ensure they are loading the correct modules

    /etc/rc.php_ini_setup

    If any additional packages were installed, reinstall them manually using the GUI if possible, or using "pkg install -f" as above.

    En otros hilos del foro he visto que, desde shell con:

    
    pkg update -f
    
    

    Parece que se soluciona.

    Salu2



  • Gracias por el aporte me ayudo bastante, al realizar el procedimiento tras usar el comando

    /usr/sbin/pkg install -yf pkg pfSense pfSense-kernel-pfSense

    da un mensaje de:

    Locking package pfSense-kernel-pfSense_wrap

    busque un poco en el foro y encontré este hilo:

    https://forum.pfsense.org/index.php?topic=113765.0

    al final indican que se actualice con los siguientes comandos

    pkg update -f
    pkg upgrade -f

    El primero lo mencionas faltaba el segundo y no seria necesario lo demás es la forma de actualizar desde el Shell.

    Al final quede con la versión 2.3.2 con acceso a los paquetes..

    mil gracias de nuevo



  • Hola

    Me alegro que se solucione (pon [SOLUCIONADO] en el post ) :)

    Si buscas en el foro, he visto que otra forma de solucionarlo es lanzar desde el menú de consola la opción 13:

    1. Update from console

    Salu2


Log in to reply