Can't access webGUI from a specific address to a specific address…?



  • Background


    So… I was doing a new install of pfsense (a new VMware instance) to replace a previous install that was bugging out on me.

    The old pfsense was located at 192.168.1.1.

    While setting up the new pfsense, I used 192.168.1.2.

    When I was ready to do the switchover, I changed old pfsense to 192.168.1.3 and then moved the new pfsense to 192.168.1.1.

    Problem


    After moving the new pfsense to 192.168.1.1, I can no longer access the webGUI from the specific machine which I always use to manage my network.

    Symptoms


    • I can still ping 192.168.1.1, I just can't access the webGUI.

    • I'm using 192.168.1.1 as my default gateway, so communication with the pfsense is otherwise fine.

    • If I use a different computer on the network, I can access the new pfsense at 192.168.1.1 just fine, so I know that the webGUI is functioning correctly.

    • I've tried rebooting the pfsense box several times and the webconfigurator specifically with no success.

    • If I change the IP of the new pfsense box back to 192.168.1.2, I can access it again normally.

    • I can access the old pfsense box at 192.168.1.3 just fine.

    So it is just this one computer, which was able to access the old pfsense webGUI at 192.168.1.1 just fine, which now can't access the new pfsense webGUI at the same address.

    Why?



  • Points to a potential cache/certificate/other problem with that computer's Web browser.

    Try to clear the browser cache, reboot the computer, use another browser.

    In other words, fix the problem with that computer…...



  • Ya actually I was just about to post a followup here…

    I usually use IE or Chrome, and both were giving me the same problem, so I decided to try Firefox, and it worked!

    So I looked a little bit closer at what was going on, and it seems IE and Chrome were both automatically forwarding the connection for http://192.168.1.1 to https://192.168.1.1.  I guess my previous install of pfsense supported https out of the box, but this new install does not.  So Chrome decides it should always forward 192.168.1.1 to https because it did so before, and the new pfsense install refuses the connection.

    Firefox has never connected there before (nor the other computers on the network that I tried), so it just goes with the plain http connection.

    So now I have several questions, because this problem is still annoying, most of which don't really belong in this forum:

    1. How can I stop Chrome and IE from auto-forwarding my explicit typing of http://192.168.1.1 to https?
    I found this: http://superuser.com/questions/304589/how-can-i-make-chrome-stop-caching-redirects  and this: http://superuser.com/questions/565409/chrome-how-to-stop-redirect-from-http-to-https
    2. Alternatively, how can I make pfsense support https connections for the webGUI like it did before (I never turned it on before so I thought it was enabled by default)?



  • Look for a way to clear your browser HSTS cache


Log in to reply