Squid failed to install after upgrading to 2.3.2



  • I removed all packages prior to upgrading. Now squid install failed with the following error. I tried one of the bug fix tar xv -C / -f /usr/local/share/pfSense/base.txz ./usr/bin/install. but it did not resolve the issue. thoughts?

    ===> Creating users
    Creating user 'clamav' with uid '106'.
    pw: uid 106' has already been allocated Adding user 'clamav' to group 'mail'. pw: userclamav' does not exist
    pkg: PRE-INSTALL script failed
    Failed



  • Hi.

    I had the same problem and found solution.

    So go to “Diagnostics->Command Prompt“.

    Type the command below on “Execute Shell command” and click ‘Execute‘.

    pw useradd clamav -G wheel

    Type again the command below on “Execute Shell command” and click ‘Execute‘.

    pw usermod clamav -G wheel

    Now try to install squid again.  ;)