Open-VPN RDP



  • I Have almost everything working but there is wired issue

    I have my pfsense 2.3.2 setup with Squid (Cache and Gateway antivirus), Squid Gurad, Open-VPN

    I can connect using Open-VPN on iPhone and RDP into my pc but when I use Open-VPN on a PC I can connect but can’t RDP to my pc

    please help


  • Rebel Alliance Global Moderator

    and what is the network your pc is on?  If your local network is the same as your remote network your going to have a bad day.



  • ok I did some further testing from different locations

    it seams

    from another person home it works both with connecting to VPN and RDP

    from my cellular service I can both

    but at work
    we have a gest network were my iPhone was connected to. that worked and it uses a different gateway than the main network
    but the pc from the main network it did connect to my VPN but can’t seem to connect to RDP

    but it did work once before I turned on the squid proxy and squid guard now even if I turn it off I doesn’t work. But why only the main network at my work it does not work I don’t understand


  • Rebel Alliance Global Moderator

    Dude what is the IP address you get on your machine main network??  You sure its not the same network as your home network.

    If your work network is 192.168.0.0/24 and your home network is 192.168.0.0/24 your not going to work..



  • im using 10.1.1.0 they are using 10.10.0.0

    i had the same setup on my sonicwall that i replaced with the pfsense and it worked for years


  • Rebel Alliance Global Moderator

    And what is the masks on those networks if one is /8 then your going to have issues huh!

    So on your machine lets see routes, do a traceroute to your rdp box..



  • both net work using /24

    and when i use trcae route to my pc from work it reaches the gateway but get request timeout afterwards


  • Rebel Alliance Global Moderator

    so it gets to pfsense, ie your vpn gateway?

    Did you put some rules in floating or vpn tab?  Are you using any sort of specific gateways on your rules, does the box your wanting to rdp to use pfsense as gateway.

    Do a sniff on pfsense interface that rdp box is connected too, do you see the traffic going to to your rdp box?  Do you get an answer?



  • i Forgot to write the solution to my problem it was the work computer
    that didn’t have the administrate rights so when i logged I can but it didn’t allow to write the network path in the
    host name file it was logged in the Open VPN client log