Problema con Vlans



  • La verdad que desde que conoci PFSENSE he pensado seriamente en cambiar el firewall de la empresa que actualmente lo tengo montado en una maquina DEBIAN con iptables. Asi que harme una maquina con un procesador Pentium 4 de 3 Ghz. , 2 G.B de memoria RAM, y dos tarjetas de red D-LINK DFE 530tx 10/100 obviamente una de la wan y la otra lan. Mi problema es el siguiente:

    en la Lan me levanta super bien la interfaz de rango 192.168.x.x, el DHCP funciona Super bien, y si me asigno ip en forma manual todo bien tambien. luego levante una vlan de clase b con puerta de enlace 172.16.1.1 / 24. incluso yo estando bajo el segmento de clase c puedo hacer ping a la puerta de enlace 172.16.1.1 . sin embargo cuando me cambio hacia el otro segmento todo muerto. no funciona el dhcp siendo que deshabilito el otro porsiacaso, me pongo ip en forma manual, en incluso cambie hasta la mascara de red porsiaca. y nada todo muerto… no tengo ping hacia ningun lado.
    Asi que quisiera saber si es que alguien tiene los pasos justos para levantar la Vlan y ver si el error esta entre el teclado y la silla, o si simplemente las vlans no funcionan bien con este tipo de tarjetas.

    y en el caso de que las soportora, necesito levantar 16 VLANS, que es lo que tengo levantado en el debian sin ningun problema... ¿Como se comportorian? si es que alguien tiene una red grande y trabaja con PFSENSE que me cuente un poco su experiencia... Saludos a todos... ;)



  • ¡Hola!

    ¿Qué versión de pfSense estás probando?

    Al parecer esta tarjeta de D-Link emplea el driver vr(4) de FreeBSD:

    http://www.freebsd.org/cgi/man.cgi?query=vr&apropos=0&sektion=0&manpath=FreeBSD+6.2-RELEASE&format=html

    y tenía un problema precisamente con VLAN hasta FreeBSD 6.3:

    http://forum.pfsense.org/index.php?topic=10337.msg58765

    Tendría que estar resuelto porque los desarrolladores de pfSense modificaron el kernel para incluir el parche (pfSense 1.2 está basado en FreeBSD 6.2). Por ello te preguntaba ¿qué versión de pfSense empleas?

    Saludos,

    Josep Pujadas



  • si, instale la version 1.2, …entonces como puedo hacer un upgrade del kernel? o acaso existe un version de pfsense con un kernel mas actualizado???



  • ¡Hola!

    Guarda la configuración (config.xml) de tu pfSense en lugar seguro. La interfase gráfica lleva una opción para hacerlo.

    A continuación haz un upgrade desde la propia interfase gráfica. Si hay una versión nueva se actualizará tu pfSense.

    Si no puedes actualizar la versión que tienes tendrías que reinstalar con la 1.2.1 Beta, http://blog.pfsense.org/?p=207 que está basada en FreeBSD 7.0 precisamente para dar mayor soporte de hardware.

    Después de la reinstalación vuelve a cargar tu config.xml que habías guardado en lugar seguro.

    ¡Suerte!

    Josep Pujadas


Log in to reply