Getting Warning: require_once(Net/IPv6.php): failed to open stream: No such file



  • I have no access to the pfSense GUI, all I see is the warning.

    The full message is below.  I just updated to the latest snapshot, probably this one (2.3.3-DEVELOPMENT-amd64-20160812-1135) https://snapshots.pfsense.org/amd64/pfSense_RELENG_2_3/updates/pfSense-CE-Full-Update-2.3.3-DEVELOPMENT-amd64-20160812-1135.tgz

    I see in github that there was a change to /etc/inc/config.inc two days ago related to IPv6 (Ticket #3734: Replace etc/inc/IPv6.inc by pear-Net_IPv6 port)
    here: https://github.com/pfsense/pfsense/tree/master/src/etc/inc

    commit: https://github.com/pfsense/pfsense/commit/470fddb1c89559a8d6749cb9769c1d5f49395130

    Warning: require_once(Net/IPv6.php): failed to open stream: No such file or directory in /etc/inc/config.inc on line 51 Call Stack: 0.0001 226864 1. {main}() /usr/local/www/index.php:0 0.0001 232176 2. require_once('/usr/local/www/guiconfig.inc') /usr/local/www/index.php:40 0.0003 253040 3. require_once('/etc/inc/authgui.inc') /usr/local/www/guiconfig.inc:46 0.0003 253624 4. include_once('/etc/inc/auth.inc') /etc/inc/authgui.inc:25 0.0003 254072 5. require_once('/etc/inc/config.gui.inc') /etc/inc/auth.inc:30 0.0007 275824 6. require_once('/etc/inc/notices.inc') /etc/inc/config.gui.inc:37 0.0007 276232 7. require_once('/etc/inc/functions.inc') /etc/inc/notices.inc:24 0.0008 276608 8. require_once('/etc/inc/interfaces.inc') /etc/inc/functions.inc:139 0.0009 277096 9. require_once('/etc/inc/gwlb.inc') /etc/inc/interfaces.inc:29 0.0018 280112 10. require_once('/etc/inc/config.inc') /etc/inc/gwlb.inc:23 Fatal error: require_once(): Failed opening required 'Net/IPv6.php' (include_path='.:/etc/inc:/usr/local/www:/usr/local/captiveportal:/usr/local/pkg:/usr/local/www/classes:/usr/local/www/classes/Form') in /etc/inc/config.inc on line 51 Call Stack: 0.0001 226864 1. {main}() /usr/local/www/index.php:0 0.0001 232176 2. require_once('/usr/local/www/guiconfig.inc') /usr/local/www/index.php:40 0.0003 253040 3. require_once('/etc/inc/authgui.inc') /usr/local/www/guiconfig.inc:46 0.0003 253624 4. include_once('/etc/inc/auth.inc') /etc/inc/authgui.inc:25 0.0003 254072 5. require_once('/etc/inc/config.gui.inc') /etc/inc/auth.inc:30 0.0007 275824 6. require_once('/etc/inc/notices.inc') /etc/inc/config.gui.inc:37 0.0007 276232 7. require_once('/etc/inc/functions.inc') /etc/inc/notices.inc:24 0.0008 276608 8. require_once('/etc/inc/interfaces.inc') /etc/inc/functions.inc:139 0.0009 277096 9. require_once('/etc/inc/gwlb.inc') /etc/inc/interfaces.inc:29 0.0018 280112 10. require_once('/etc/inc/config.inc') /etc/inc/gwlb.inc:23



  • Have you done any gitsync lately?

    This code has appeared on 'master' branch, but is not present on RELENG_2_3 (the branch that 2.3.3 snapshots are built from).



  • The only way I see for you to fix this problem is to reinstall all packages aggressively.

    pkg update -f
    pkg upgrade -f
    

    Run this on console. Hopefully that still works to a certain extent, and you might be lucky enough and be able to fix this.

    See this post as well:
    https://forum.pfsense.org/index.php?topic=109690.msg610721#msg610721

    Lastly, force an upgrade of all installed packages:

    pkg upgrade -f
    

    If an error is shown that the kernel package is locked, you can unlock it with "pkg unlock <name>" replacing <name>with what the error complains about, then run the "pkg update -f" command again. Be sure to lock it back after you're done.</name></name>



  • Wow thanks for that tip, to even get back online I did have to first manually change all 5 of the changed files that referenced ("Net/IPv6.php") back to ("IPv6.inc") from that commit, and then run dhclient em1 and add 'nameserver 8.8.8.8' manually to /etc/resolv.conf before I could actually run the pkg update/upgrade -f

    I also manually removed the


Log in to reply