WebGUI can't delete or edit static routes or create new interface



  • So I recently upgraded from 2.2.6 x64 to 2.3.2. I'm trying to delete a static route, but the webGUI just won't do it. I've tried to edit the static route, disable it and save it, but when I reload the config it is still the same. Reboots haven't helped.

    The same thing happened when I tried to add a new interface. It would add, I'd save it, then when I clicked on the new Opt interface, it would take me to the WAN interface configuration. I had to add the interface from the console.

    Any idea what's broken here?



  • It appears that the built-in admin account can successfully make changes, so it must be a permissions issue with our LDAP link. Weird that it still lets me log in, though. I'll update when I figure it out.



  • After the upgrade, it appears that the LDP extended query check box became unchecked. Rechecking it showed it still had the same information stored, but upon saving I still couldn't make changes to anything. Still working on it.



  • I'm stumped. I've tested the extended query and it pulls the users from the security group. Also, this used to work in 2.2.6. If I edit the LDAP auth settings and choose the option to select a container when the container text field is already filled in, the OUs show up. If the Auth container is empty, I'm told I have to "Please fill in the required containers".

    At any rate, I know that the AD query is valid. The pfSense-Admins security group has 2 users in it, but these users are not pulled into the group if pfSense (member count is 0).

    Any ideas?



  • I'm actually going to move this to General Questions because I don't think it's an issue with the GUI.


Log in to reply