Problema con Multiwan SOLUCIONADO



  • Hola amigos soy nuevo en este foro y en el mundo de pfsense, les expongo mi caso:
    Tengo una pequeña empresa proveedora de Internet Wifi en Venezuela tengo 2 adsl aba cantv con 30 clientes por cada linea con 2 servidores en m0n0wall y hasta ahora funciona bien pero quiero simplificar y montar un solo servidor con pfsense y manejar todos los clientes desde alli he aqui la cosa, instale la ultima version de pfsense en una maquina con 3 placas de red una para lan, otra para wan1 y otra para wan2 hasta aqui todo bien.

    Configure una placa red para wan 1 con  la ip publica dinamica que me da cantv asignada por dhcp
    Configure una placa red para wan 2 con  la ip publica dinamica que me da cantv asignada por dhcp
    configure una placa red para lan con la direccion 192.168.10.10
    active dhcp para lan en este rango 192.168.10.20 – 192.168.10.100 para los clientes
    Hasta aqui todo va bien reviso el status de las interfaces y estan online

    me voy a Routing de mi pfense y edito las Gateway de cada WAN pero no le coloco direccion ip fija sino que la dejo por DHCP me voy a GATEWAYS GROUP y creo un grupo nuevo con las 2 wan, les coloco tier2 a cada WAN.

    Luego me voy hasta RULES de mi pfsense y creo una regla en la LAN le doy PASS por ANY protocolo y en la GATEWAY coloco el grupo de GATEWAYS hasta aqui bien-

    Me voy a STATUS GATEWAY de mi pfsense y aparecen online las 2 WAN y por la lan hay conexion a internet bien, luego me dispongo a probar que la regla si funcione y hago las siguientes pruebas:

    1 entro a la pagina http://www.cual-es-mi-ip.net/ y me muestra la ip de la WAN1 que esta default en el pfsense, navega bien

    2 desconecto el cable de la WAN1 para probar que la WAN2 tome el control y haya internet por la LAN pero no es asi no abre ninguna pagina y en el STATUS GATEWAY esta online, aqui es el problema...

    Quisiera saber que estoy haciendo mal o si debo asignarles ip fijas a las GATEWAYS para que funcione.

    AYUDA POR FAVOR
    GRACIAS DE ANTEMANO



  • Bien, lo primero es conocer la velocidad de los dos canales wan 1 y wan 2, como esta haciendo balanceo de carga si los canales son idénticos no hay problema si son distintos se debe ajustar su peso para que PFsense funcione de forma optima.

    Por otra parte en la configuración de cada gateway debe asignar un monitor, pero ojo es común colocar los de google 8.8.8.8 o 8.8.4.4 que funcionan de maravilla cuando solo se tiene una wan cuan do hay 2 esto no es lo optimo pues al ser públicos pueden ser resueltos por el otro gateway y mostrar que no hay caída.

    Por lo anterior sugiero hacer un tracer y usar como monitor IP, uno de los primeros saltos del proveedor luego del gateway asignado.

    Algo mas a tener en cuenta es el Trigger Level que asigne en el balanceo



  • Gracias si te informo que las 2 wan tienen la misma velocidad y cada una le coloque un monitor diferente a cada una y para realizar la prueba desconecto el cable de la primera y la segunda queda online pero no navega a internet por la lan, en realidad no se que estare haciendo mal



  • Buen día, por favor coloca imágenes de como tiene configurado el balanceo y las reglas de salida, de ese modo podemos validar mejor que hace falta.

    un saludos



  • Amigos aqui estan las captures de lo que hice en el pfsense, de acuerdo a lo que me dijeron y cosas que lei hace lo siguiente
    1 Balancea bien los 2 WAN
    2 Al desconectar el WAN2 sigue saliendo INTERNET por la LAN
    3 Al conectar WAN2 vuelve a balacear y bien…
    4 Al desconectar WAN1 y dejar WAN2 conectada se cae por completo el internet y lo muestra ONLINE en el dashboard...
    asi que no se si las reglas que puse estan bien o hay algo que me falta en el septup general con respecto a las GATEWAYS o no se si habra que usar cables cruzados o crossover en las WAN (en m0n0wall es asi obligatorio)...
    Les agradeceria su ayuda gracias de antemano


























  • Buen día Amigo

    Te falta una configuración, en System > Advanced > Miscellanous en la sección load balancing, habilita los check "Use sticky connections" y "Enable default gateway switching" para que cuando se caiga la WAN por defecto conmute al siguiente disponible.



  • Comparto  +1

    @Aleximper:

    Buen día Amigo

    Te falta una configuración, en System > Advanced > Miscellanous en la sección load balancing, habilita los check "Use sticky connections" y "Enable default gateway switching" para que cuando se caiga la WAN por defecto conmute al siguiente disponible.



  • SOLUCIONADO GRACIAS AMIGOS
    Les cuento que de acuerdo a sus instrucciones se soluciono el problema con las reglas que me dijeron y con la  configuración, en System > Advanced > Miscellanous en la sección load balancing,  "Enable default gateway switching" solamente  porque si se habilita los check "Use sticky connections" solo en el balanceo envia peticiones por la WAN1 solamente

    muchas gracias a win_bar y aleximper



  • Muy Bien, coloca SOLUCIONADO en el subject del post


Log in to reply