SquidGuard - cannot download blacklist from blacklist tab [Solved]



  • Hi,

    I already used PfSense in the past and I'm now looking to reinstall one for a school. (It was so nice :))

    I was able to install everything (on laptop without screen, with vlan, with captive portal, squid proxy, …)
    but I'm stuck on the SquidGuard install :s

    when I click on download, it just show me a blank empty sqare and then directly refresh the page.

    before clicking :

    after clicking (during <1 sec) :

    and then it comes back to the first screenshot, suggesting again to download/cancel/reset default…

    I already
    ...tested the link : it works
    ...tested from pfSense : internet is ok
    ...looked for errors in logs : I didn't find anything :(
    ...change the owner and permissions on DB folder (/var/db/squidGuard/) : still same behaviour...
    ...reinstalled the whole thing in virtualbox with almost same settings : exactly same issue

    does anyone have the same issue ? is it due to a bug in last version ?

    Here is the versions I got :
        pfSense 2.3.2-RELEASE (i386)
            built on Tue Jul 19 13:09:39 CDT 2016
            FreeBSD 10.3-RELEASE-p5
        New packages to be INSTALLED:
    pfSense-pkg-squidGuard: 1.14_3 [pfSense]
    squidGuard: 1.4_15 [pfSense]
    db5: 5.3.28_4 [pfSense]

    don't hesitate to suggest your idea :)
    I spent the whole day on this…

    Thanks,
    Laurenzzo



  • Hi,
    here are some updates on my searches

    I tried to redo the whole config with pfSense version 2.0 ==> package not available (I believe it's because the version is too old). I so tryed to upgrade it ==> not possible neither… (I believe it's also due to very old version.

    I tried to redo the whole config with pfSense version 2.3(.0) ==> exactly same issue.
    (able to download and configure package, then nothing after clicking on download...)

    Please help if you have any ideas, I really want to use this powerfull system that I knew  :D

    Thanks,
    Laurenzzo



  • I had the same issue, and when i searched in the PACKAGES area here, I found that others with this problem had discovered that it was related to the browser they were using.  It turns out that Firefox (which I use) would have this issue, but IE and EDGE don't.  EDGE and IE resolved it for me so I use those instead of Firefox for pfSense webgui.



  • Thank you so much Tzvia !!! :-*

    It was indeed the cause ! Stupid Firefox !
    I was thinking FF was fully supported with pfSense webconsole. All others features seem to be alright…
    I waste so many hours for this simple thing ...

    Thanks thanks thanks  :D


Log in to reply