Freeradius not subtract the Session Timeout when user query from mysql



  • Hi guys,

    Because some reasons, so I use mysql to locate all customer users and Freeradius will query from it to authen. The authentication work well but the user never expired because freeradius dont subtract the Session-Timeout when user connect the Internet.
    I already set the Max-Daily-Session :=500 like this in radcheck table.
    4c-66-41-5f-aa-cd | Max-Daily-Session | := | 500

    [2.3.2-RELEASE][admin@pfSense.localdomain]/root: radtest 4c-66-41-5f-aa-cd radpass 127.0.0.1 0 rath0066
    Sending Access-Request of id 71 to 127.0.0.1 port 1812
            User-Name = "4c-66-41-5f-aa-cd"
            User-Password = "radpass"
            NAS-IP-Address = 172.29.151.111
            NAS-Port = 0
            Message-Authenticator = 0x00000000000000000000000000000000
    rad_recv: Access-Accept packet from host 127.0.0.1 port 1812, id=71, length=26
            Session-Timeout = 500
    [2.3.2-RELEASE][admin@pfSense.localdomain]/root: radtest 4c-66-41-5f-aa-cd radpass 127.0.0.1 0 rath0066
    Sending Access-Request of id 111 to 127.0.0.1 port 1812
            User-Name = "4c-66-41-5f-aa-cd"
            User-Password = "radpass"
            NAS-IP-Address = 172.29.151.111
            NAS-Port = 0
            Message-Authenticator = 0x00000000000000000000000000000000
    rad_recv: Access-Accept packet from host 127.0.0.1 port 1812, id=111, length=26
            Session-Timeout = 500



  • Why not set the hard-timeout in your captive portal settings directly? It's under Services/Captive Portal, then choose the CP instance and set the Hard Timeout setting to whatever you like.


Log in to reply