LTE configuration for MC7700 AT&T



  • I've been messing with this for almost a month now and I've had no luck getting this to work. The guides and forum posts I've read indicate I'm doing this correctly but I get nothing but errors.

    Time Process PID Message
    Aug 30 18:02:39 ppp [opt1_link0] Link: reconnection attempt 3 in 4 seconds
    Aug 30 18:02:39 ppp [opt1_link0] LCP: Down event
    Aug 30 18:02:39 ppp [opt1_link0] Link: DOWN event
    Aug 30 18:02:39 ppp [opt1_link0] MODEM: chat script failed
    Aug 30 18:02:39 ppp [opt1_link0] CHAT: Invalid dial init string.
    Aug 30 18:02:39 ppp [opt1_link0] CHAT: ATDT*99#
    Aug 30 18:02:39 ppp [opt1_link0] CHAT: Dialing server at 99#…
    Aug 30 18:02:39 ppp [opt1_link0] CHAT: Detected Hayes compatible modem.
    Aug 30 18:02:39 ppp [opt1_link0] CHAT: +CGDCONT=1,"IP","broadband"
    Aug 30 18:02:39 ppp [opt1_link0] Link: reconnection attempt 2
    Aug 30 18:02:36 ppp [opt1_link0] Link: reconnection attempt 2 in 3 seconds
    Aug 30 18:02:36 ppp [opt1_link0] LCP: Down event
    Aug 30 18:02:36 ppp [opt1_link0] Link: DOWN event
    Aug 30 18:02:36 ppp [opt1_link0] MODEM: chat script failed
    Aug 30 18:02:36 ppp [opt1_link0] CHAT: Invalid dial init string.
    Aug 30 18:02:36 ppp [opt1_link0] CHAT: ATDT
    99#
    Aug 30 18:02:36 ppp [opt1_link0] CHAT: Dialing server at *99#…
    Aug 30 18:02:36 ppp [opt1_link0] CHAT: Detected Hayes compatible modem.
    Aug 30 18:02:35 ppp [opt1_link0] CHAT: +CGDCONT=1,"IP","broadband"
    Aug 30 18:02:33 ppp [opt1_link0] Link: reconnection attempt 1

    I've got my config file posted here from the CLI because the gui doesn't show much.

    [2.3.2-RELEASE][admin@pfSense.localdomain]/var/etc: more mpd_opt1.conf
    startup:
            # configure the console
            set console close
            # configure the web server
            set web close

    default:
    pppclient:
            create bundle static opt1
            set bundle enable ipv6cp
            set iface name ppp0
            set iface disable on-demand
            set iface idle 0
            set iface enable tcpmssfix
            set iface up-script /usr/local/sbin/ppp-linkup
            set iface down-script /usr/local/sbin/ppp-linkdown
            set ipcp ranges 0.0.0.0/0 10.64.64.0/0
            set ipcp enable req-pri-dns
            set ipcp enable req-sec-dns
            #log -bund -ccp -chat -iface -ipcp -lcp -link

    create link static opt1_link0 modem
            set link action bundle opt1
            set link disable multilink
            set link keep-alive 10 60
            set link max-redial 0
            set link disable chap pap
            set link accept chap pap eap
            set link disable incoming
            set link mtu 1492
            set auth authname "user"
            set auth password <9E><89> <de>set modem device /dev/cuaU0.3
            set modem script DialPeer
            set modem idle-script Ringback
            set modem watch -cd
            set modem var $DialPrefix "DT"
            set modem var $Telephone "*99#"
            set modem var $ConnectTimeout "20"
            set modem var $APN "broadband"
            set modem var $APNum "1"
            open</de>



  • Hello jcpolo

    I am not sure if my reply will be helpful, but I noticed that you have in your PPP client config:

    set modem var $DialPrefix "DT"
    set modem var $Telephone "*99#"

    resulting in:

    Aug 30 18:02:39  ppp      [opt1_link0] MODEM: chat script failed
    Aug 30 18:02:39  ppp      [opt1_link0] CHAT: Invalid dial init string.
    Aug 30 18:02:39  ppp      [opt1_link0] CHAT: ATDT*99#

    Although a different device, I had a similar problem with my AT&T Unite Pro (Aircard 781S) connecting with an Asus RT-AC68U router and found the problem to be with the dialing string (*99#). Removing the string, leaving the number field blank, enabled the wireless modem.

    I would also try and leave the dial tone "DT" blank as well, for the AT&T wireless modem, from my limited understanding, does not actually place a traditional call or make use of a dial tone. In addition, I do not know if the pfSense PPP client will let you leave the two "set modem" lines out of the configuration or if needed to remain, permit the two fields to be blank.

    I wish I could get as far as you have with my Unite Pro on pfSense.

    Park



  • I have the same problem here, the MODEM is DLINK DWM 157, anyone have an idea?

    My regards.



  • The issue could be related to Init, not Dial string. Custom init string should be set to ATZ (just Z in the web GUI as I recall).
    Please check what I wrote earlier here: https://forum.pfsense.org/index.php?topic=105842.msg589805#msg589805


Log in to reply