Squid Guard Groups ACL bug



  • Adding another target rule in here with the same client source no longer works. Default access [all] option should have "–-" option,  not to add "all" to target so that the next rule will with same client be executed. I separate the rules though it has same client cause I want them to redirect on different error page. Adding a redirect option in squidguard conf is okey but it will be deleted after clicking apply.

    It would be nice if we can add redirect to each dest. like the conf below

    dest blk_blacklists_adult {
    domainlist blk_blacklists_adult/domains
    expressionlist blk_blacklists_adult/expressions
    urllist blk_blacklists_adult/urls
    log block.log
    }

    to

    dest blk_blacklists_adult {
    domainlist blk_blacklists_adult/domains
    expressionlist blk_blacklists_adult/expressions
    urllist blk_blacklists_adult/urls
    log block.log
            redirect http://customeredirectpage
    }

    edit manually removing the all in acl wont work so I manualy add the redirect option in dest {} the restart squidguard  from shell. clicking apply in the gui will remove the redirect option.


Log in to reply