[Solved] - VMware 6.0-U2 - Pfsense Appliance v2.3.1 + Tools & Balloon Driver?



  • Guys,

    I have pfsense running as a VM and quite happy I am too!

    However vSphere keeps moaning about excessive paging even though the VM has 1Gb of RAM and is only using 19% of that. Furthermore it's not even touching the 2Gb Swap partition.
    Reading about I have seen suggestions that this is because the "this can occur if the VMware tools have not been installed in a VM or if the vmmemctl (balloon) memory driver has been disabled,"

    I have installed the VMware tools package (version:2147483647 - Guest Managed) from the package menu and all seems fine but if I run the command "kldstat" (as some have suggested) it doesn't seem to show any of the modules are running?

    Id Refs Address            Size     Name
     1    1 0xffffffff80200000 225ed50  kernel
    

    Could this be the problem?

    So in summary:

    • What version of PFsense should I be running on vSphere 6.0U2 and what should the Hardware version of the VM be set to? (currently version 8 )

    • How can I confirm the balloon driver within the tools is functioning correctly?

    Thanks Gents.



  • Try disabling ballooning or dynamic RAM sizing for the VM.



  • Apparently the way to do that is to set the reservation to maximum.

    https://blogs.vmware.com/vsphere/2012/02/disable-ballooning.html

    Disabling the balloon-driver will likely worsen the performance of the virtual machine and drives the problem down the stack. If you want to disable memory reclamation for that virtual machine, apply reservations.

    I tried this but the VM is still swapping, (after a reboot),

    But looking at the above image it looks like I actually need to apply more RAM to the VM even though the pfsense web interface suggests that it not even being touched,

    There seems to be a disconnect in what VMware shows and what the pfSense web interface shows?
    Any input welcome but I am reluctant to just keep adding RAM if it is going to be gobbled up and not used …

    Cheers



  • I  think this is now solved - I only ever reboot my firewall when I upgrade the OS ( because it is so stable  :P )
    It seems to get the tools to function correctly you have to reinstall them under the package menu and then reboot the firewall one more time.



  • It does help to reboot once the new tools are there indeed :p Then VMW and BSD both know about their capabilities and it actually works ;-)


Log in to reply