Adding VLAN interface removes OpenVPN interface



  • Restart doesn't work. Have to delete OpenVPN server and re-add.

    2.3.2-RELEASE (i386)
    built on Tue Jul 19 13:09:39 CDT 2016
    FreeBSD 10.3-RELEASE-p5

    Aug 31 14:11:39 openvpn 50596 Exiting due to fatal error
    Aug 31 14:11:39 openvpn 50596 FreeBSD ifconfig failed: external program exited with error status: 1
    Aug 31 14:11:39 openvpn 50596 /sbin/ifconfig ovpns1 192.168.12.1 192.168.12.2 mtu 1500 netmask 255.255.255.248 up
    Aug 31 14:11:39 openvpn 50596 do_ifconfig, tt->ipv6=1, tt->did_ifconfig_ipv6_setup=0
    Aug 31 14:11:39 openvpn 50596 TUN/TAP device /dev/tun1 opened
    Aug 31 14:11:39 openvpn 50596 Control Channel Authentication: using '/var/etc/openvpn/server1.tls-auth' as a OpenVPN static key file
    Aug 31 14:11:39 openvpn 50596 NOTE: the current –script-security setting may allow this configuration to call user-defined scripts
    Aug 31 14:11:39 openvpn 50351 library versions: OpenSSL 1.0.1s-freebsd 1 Mar 2016, LZO 2.09
    Aug 31 14:11:39 openvpn 50351 OpenVPN 2.3.11 i386-portbld-freebsd10.3 [SSL (OpenSSL)] [LZO] [MH] [IPv6] built on May 16 2016


  • Rebel Alliance Developer Netgate

    Aug 31 14:11:39   openvpn   50596   FreeBSD ifconfig failed: external program exited with error status: 1
    

    That means the IP address it's trying to use for the tunnel network is already in use – either on another interface or it's in the routing table somehow (e.g. from quagga). Figure out what is conflicting and fix that, and your problem will go away. If it's quagga, disable redistribution and acceptance of 192.168.12.1/32 for example.