Failed to update 2.1.5 to 2.3.2 in captive portal (solved)



  • Good afternoon I have problems with the upgrade, actualize the 2.1.5 to 2.3.2 and the captive portal if you open on computers , only to press the start button , not connected , stays charging and mark error because check the code of the index page and the code is correct . which will be the problem.

    Regards!! :'( :'(



  • You're using the default, built-in "login" page ?

    What do you mean by the "start button" ?



  • This is the portal and the code encesita for login.

    ![portal cautivo fpgal.jpg](/public/imported_attachments/1/portal cautivo fpgal.jpg)
    ![portal cautivo fpgal.jpg_thumb](/public/imported_attachments/1/portal cautivo fpgal.jpg_thumb)
    ![portal cautivo fpgal code.jpg](/public/imported_attachments/1/portal cautivo fpgal code.jpg)
    ![portal cautivo fpgal code.jpg_thumb](/public/imported_attachments/1/portal cautivo fpgal code.jpg_thumb)



  • Your portal html file won't work.
    Use the default 'html login' page - and compare that on with yours.



  • I will review what he says, but before the update was working properly.



  • @gmendoza:

    … but before the update was working properly.

    Knowing that the internals of the captive portal changed, an 'old' hand made html file won't work any more.



  • He was running my captive portal, change some of the code to make actualizacón, check with the portal that is predetermined, have if anything was missing and add it to my original html and it worked correctly.

    That was my code:

    <form method="post" action="http://192.168.10.1:8002/index.php?zone=cpzone">

    User  :

    Pass  :

    Ticket:

    -->

    </form>

    Thank you!!



  • Some advise :
    @gmendoza:

    That was my code:

    This

    is better.

    Condition : Your DNS should work. Your should set  as instructed when installing, a domaine like "mylocalpfsense.tld" and a host name like "pfsense".
    Also - if your portal is running on a separate interface (it real should) - a host name for your portal's gateway should be set

    Do NOT hard code something like "zone=cpzone".

    Include the new :

    do not hard code like

    New stuff might appear when upgrading - even if your settings are maintained, sometime you will have to 'retouch' something.
    This is why the CP didn't seem to work when you upgraded from ancient pfSense versions.

    ( => never keep old software except when you are an expert. - Note : experts never keep old versions around, the do not have time for that  ;))