Captive portal login issue



  • Hi all,

    I try to setup a CP so users need to login.

    what works is, when i type http://www.google.com or a http:// website i get the login page when i use https:// websites it keep loading and nothing happens.

    after typing the user and pass i go to a 404 page and do not get redirected to the redirect page.

    on the wifi network when I logon i get directly a login page, also same issue after login 404 page.
    after logging into CP and select a new domain like msn.com everything works, pinging to differecnt website works

    what can I do to it working so if a user opens a webpage it gets the login page and when logging in he gets redirected?
    pfsense version is 2.3.2



  • @newbie_sense:

    ….
    what works is, when i type http://www.google.com or a http:// website i get the login page when i use https:// websites it keep loading and nothing happens.
    ....

    This is normal.

    What your really want to happen : when  you navigate to a https site, your are saying : I want to conecte to this https://….. site and nothing else (no man in the midddle) - your communication should be protected from YOU up to the https:// site.
    pfSense will not - and your browser WILL NOT let others interfere.

    So, all is well ;)

    @newbie_sense:

    after typing the user and pass i go to a 404 page and do not get redirected to the redirect page.

    on the wifi network when I logon i get directly a login page, also same issue after login 404 page.
    after logging into CP and select a new domain like msn.com everything works, pinging to differecnt website works

    what can I do to it working so if a user opens a webpage it gets the login page and when logging in he gets redirected?
    pfsense version is 2.3.2

    Not very clear.
    What "404" page ?

    Read this : https://forum.pfsense.org/index.php?topic=118165.msg654488#msg654488 and check if DNS is working as soon as you connected to the 'wifi' network, but didn't authenticity against pfsense yet.



  • First all thank you for your answer,

    To start it's good to know its a normal behaviour of pfsense that you need to use http, just what can i do that when some login to the network they get the inlog page first before typing a http page?
    use http connection with a certificate?
    Just need to find a way so when opening a page it gets redirected to login page, any idea's?

    To give some more info on everything. i tested mostly on a wired connection to see if CP would work.
    while this would not be my setup later and guest can ONLY connect through WIFI i am using my mobile and laptop to test the rest.

    1: my mobile, when wifi is off and I enable it I will be redirected to the CP inlog page, this works
    even when there is a timeout in the connection a refesh page or new page will redirect to login page.
    just my own phone it stopped working while my tablet doesn't

    2: on my laptop when i connect it gives me a dns that i dont have listed in pfsense anywhere. when i manually enter the correct DNS and then use a http site i get the inlog page as well. only this is not the way i need it.
    for some reason i do not get it configured that when i enable wifi on the laptop it gets the rigth DNS.
    enabled DNS forwarder and enterd the DNS that shows on the first page of pfsense in CP and in DCHP but no luck on that yet, it still gives the same DNS 192.168.3.100 while it should be 192.168.3.254 to get the internet working.

    I did a complete reinstall for some reasons because i had also some packages installed like squid proxy and other stuff, after the reinstall wireless gets a proper DNS without having DNS forwarder enabled

    for the 404 page, when you enter the user and pass you get a redirect page only it does not redirect, after login i get IP:8002/www.domainname.com and i use the original login page from pfsense.
    normally it should redirect to the domain but it isnt.

    found the solution that it redirects to the proper page, i had www.domainname.com but it has to be http://www.domainname.com so it will be redirected