Недоступность по сети через сутки



  • Здравствуйте,

    установлен pfSense (NanoBSD) 2.3.2 на железо WatchGuard.
    Наблюдаю следующую ошибку: спустя примерно сутки машина внезапно недоступна по
    сети. Консоль (com-Port) работает без проблем. Попытка пропинговать другую машину
    в этой же подсети заканчиватся ошибкой:

    ping: sendto: No route to host

    Маршрут по умолчанию и маршрут сети прописаны и опрашиваются по netstat -rn
    Сам сетевой интерфейс имеет линк.
    В логах ничего страшного не находится.
    Ситуация лечится простой перезагрузкой железа.
    Сталкивался ли кто-нибудь с подобной проблемой? Подскажите пожалуйста, где
    (в каких логах) искать подобные ошибки?
    Заранее благодарен.



  • Доброе
    Железо (в том числе и cf-карта), кабель, свитчи.

    Зы. Как вариант - добавить в крон ребут по расписанию.



  • кабель, свитчи я надеюсь можно исключить: как я писАл, устраняется простой перезагрузкой pfsense. Может конечно что-то где-то в какой-то луп входит? Где это должно быть видно?



  • В логах. Где ж еще.

    dmesg | grep error или подобное



  • ок. там смотрел: нет ничего нового, последняя запись была сразу после загрузки т.е. примерно сутки назад, когда машина была еще доступна.



  • Коллизии на интерф. гляньте есть ли.
    На время откл. Hardware Checksum Offloading , Hardware TCP Segmentation Offloading, Hardware Large Receive Offloading и перезагр. pfsense

    Зы. Я бы слил конфиг и заменил cf-карту еще бы. Хотя бы на время.



  • вчера отключил ipv6 и перекинул на 100Мб-ный свитч. Пока работает.
    Коллизии проверил небыло на на 1Гб.
    На 1Гб с другой стороны был файерволл от софоса, с установленым Дебианом.
    Буду теперь играться с полученнымы результатами.
    Если не забуду, то отпишусь.



  • @operator:

    ping: sendto: No route to host

    Столкнулся с  аналогичной ошибкой…
    Инет отваливается  каждые 30-90 минут, помогает только перезагрузка роутера.
    Причем иногда оборудование даже пингуется снаружи и доступно через ВПН-канал, однако при выполнении ping на роутере, имеем:

    ping: sendto: No route to host

    Решение в моем случае:

    Status - Gateways
    У меня обнаружился дополнительный шлюз (с локальным адресом роутера - 192.168.0.1)
    Статутсы шлюзов были в состоянии Pending...

    после удаления этого шлюза в  System - Routing - Gateways, они перешли в состоянии Online
    Прошло 6 часов, зависания пока прекратились...



  • Вспомнил я недавно про эту ошибку, т.к. опять вылезла на подобном железе. Долго искал, пока не нашел свой же пост…
    Лечится в моем случае однозначно отключением IPv6: System/Advanced/Networking/Allow IPv6 снять галку.