Wireless Cards not seeing any SSIDs



  • Running 2.3.2 the wireless status page does not show any SSIDs for either card.  ath0_wlan1 is a set as an AP and is working. Trying to get ATH1 to connect to an AP, however with no luck.  Running 'ifconfig ath1_wlan0 scan' shows no results.  My laptop sees 5 different SSIDs.

    ath0: <atheros 9287="">mem 0xdfc00000-0xdfc0ffff irq 16 at device 0.0 on pci1
    ath0: [HT] enabling HT modes
    ath0: [HT] enabling short-GI in 20MHz mode
    ath0: [HT] 1 stream STBC receive enabled
    ath0: [HT] 1 stream STBC transmit enabled
    ath0: [HT] 2 RX streams; 2 TX streams
    ath0: AR9287 mac 384.2 RF5133 phy 15.15
    ath0: 2GHz radio: 0x0000; 5GHz radio: 0x00c0

    ath1: <atheros 9280="">mem 0xdfd00000-0xdfd0ffff irq 17 at device 0.0 on pci2
    [ath] enabling AN_TOP2_FIXUP
    ath1: [HT] enabling HT modes
    ath1: [HT] 1 stream STBC receive enabled
    ath1: [HT] 1 stream STBC transmit enabled
    ath1: [HT] 2 RX streams; 2 TX streams
    ath1: AR9280 mac 128.2 RF5133 phy 13.0
    ath1: 2GHz radio: 0x0000; 5GHz radio: 0x00c0

    ath0: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
            ether 94:39:e5:9b:a0:69
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
    ath1: flags=8802 <broadcast,simplex,multicast>metric 0 mtu 2290
            ether 04:f0:21:27:f5:6f
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect (autoselect)
            status: no carrier
    ath0_wlan1: flags=8943 <up,broadcast,running,promisc,simplex,multicast>metric 0 mtu 1500
            ether 94:39:e5:9b:a0:69
            inet6 fe80::9639:e5ff:fe9b:a069%ath0_wlan1 prefixlen 64 scopeid 0xb
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng <hostap>status: running
            ssid RollTribe channel 1 (2412 MHz 11g ht/20) bssid 94:39:e5:9b:a0:69
            regdomain 101 indoor ecm authmode WPA2/802.11i privacy MIXED
            deftxkey 2 AES-CCM 2:128-bit AES-CCM 3:128-bit txpower 20 scanvalid 60
            protmode OFF ampdulimit 64k ampdudensity 8 shortgi wme burst -apbridge
            dtimperiod 1 -dfs
    ath1_wlan0: flags=8c02 <broadcast,oactive,simplex,multicast>metric 0 mtu 1500
            ether 04:f0:21:27:f5:6f
            inet6 fe80::6f0:21ff:fe27:f56f%ath1_wlan0 prefixlen 64 tentative scopeid 0xc
            nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng
            status: no carrier
            ssid Troy_NG channel 6 (2437 MHz 11g ht/40+)
            country US ecm authmode WPA1+WPA2/802.11i privacy OFF txpower 27
            bmiss 7 scanvalid 60 protmode OFF ampdulimit 8k ampdudensity 8 shortgi
            wme burst</performnud,auto_linklocal></broadcast,oactive,simplex,multicast></hostap></performnud,auto_linklocal></up,broadcast,running,promisc,simplex,multicast></performnud,auto_linklocal></broadcast,simplex,multicast></hostap></performnud,auto_linklocal></up,broadcast,running,simplex,multicast></atheros></atheros>



  • Getting closer, but still can not get pfSense to connect to a AP.  After reading another post, I set the channel for the Infrastructure (BSS) mode and now ath1 can see iPhone Hotspot with ifconfig ath1_wlan0 scan.  However the scan does not think the Hotspot has WPA as a capability.

    SSID/MESH ID    BSSID              CHAN RATE  S:N    INT CAPS
    Gold64          f2:db:e2:5c:5a:4a    1  54M -84:-96  100 EP  RSN HTCAP WME

    ath1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
    ether 04:f0:21:27:f5:6f
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng
    status: associated

    ath1_wlan0: flags=8c43 <up,broadcast,running,oactive,simplex,multicast>metric 0 mtu 1500
    ether 04:f0:21:27:f5:6f
    inet6 fe80::6f0:21ff:fe27:f56f%ath1_wlan0 prefixlen 64 scopeid 0xd
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng
    status: no carrier
    ssid Gold64 channel 1 (2412 MHz 11g ht/40+)
    country US ecm authmode WPA1+WPA2/802.11i privacy MIXED
    deftxkey UNDEF txpower 27 bmiss 7 scanvalid 60 protmode OFF
    ampdulimit 8k ampdudensity 8 shortgi wme burst roaming MANUAL

    All of my other devices that connect to the Hotspot work with WPA.  I set both WPA & WPA2 in the gui and neither works.

    Any ideas?</performnud,auto_linklocal></up,broadcast,running,oactive,simplex,multicast></performnud,auto_linklocal></up,broadcast,running,simplex,multicast>



  • @CyberTiVo:

    Getting closer, but still can not get pfSense to connect to a AP.  After reading another post, I set the channel for the Infrastructure (BSS) mode and now ath1 can see iPhone Hotspot with ifconfig ath1_wlan0 scan.  However the scan does not think the Hotspot has WPA as a capability.

    SSID/MESH ID    BSSID              CHAN RATE  S:N    INT CAPS
    Gold64          f2:db:e2:5c:5a:4a    1  54M -84:-96  100 EP  RSN HTCAP WME

    ath1: flags=8843 <up,broadcast,running,simplex,multicast>metric 0 mtu 2290
    ether 04:f0:21:27:f5:6f
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng
    status: associated

    ath1_wlan0: flags=8c43 <up,broadcast,running,oactive,simplex,multicast>metric 0 mtu 1500
    ether 04:f0:21:27:f5:6f
    inet6 fe80::6f0:21ff:fe27:f56f%ath1_wlan0 prefixlen 64 scopeid 0xd
    nd6 options=21 <performnud,auto_linklocal>media: IEEE 802.11 Wireless Ethernet autoselect mode 11ng
    status: no carrier
    ssid Gold64 channel 1 (2412 MHz 11g ht/40+)
    country US ecm authmode WPA1+WPA2/802.11i privacy MIXED
    deftxkey UNDEF txpower 27 bmiss 7 scanvalid 60 protmode OFF
    ampdulimit 8k ampdudensity 8 shortgi wme burst roaming MANUAL

    All of my other devices that connect to the Hotspot work with WPA.  I set both WPA & WPA2 in the gui and neither works.

    Any ideas?</performnud,auto_linklocal></up,broadcast,running,oactive,simplex,multicast></performnud,auto_linklocal></up,broadcast,running,simplex,multicast>

    Just curious as to what model / chipset Atheros card you're using?



  • They are listed at the top of the first post ath0: <atheros 9287="">& ath1: <atheros 9280="">A little more information:  Using the TetherMe app on the iPhone.  Very little information available about the app.  Best I can tell it uses WPA2 (CCMP), no configurable settings.  The Wireless page under Status shows the iPhone SSID but the CAPS settings do not show WPA.  I know it uses WPA because my computers and iPad require it to connect.  Is it possible that pfSense (ath0 driver) does not try to connect because it does not see WPA as an option?  Of course, it does not connect if I de-select WPA.

    It sounds like the TetherMe app uses AdHoc mode.  When I put the WiFi interface in AdHoc mode, pfSense crashes and reboots continually.  I believe I read somewhere that pfSense can't use WPA in AdHoc mode, why? Doesn't make much sense.</atheros></atheros>


Log in to reply