IPV6 routing for stand-alone openvpn server



  • I'm trying to set up a stand-alone openvpn server on a windows 10 host. The client is another windows 10 host on a separate network. Everything mostly working using pki, udp, tun and redirect-gateway. I'm using internet connection sharing on the server pc. The existing LAN is prefix/64. I configured prefix+1/64 in the openvpn server, plus 10.8.0.0 for ipv4. I'm also pushing the server ipv4 address as the dns.

    I can ping and browse external addresses from the client using ipv4, but not using ipv6.

    I can ping -4 and -6 client / server in both directions.

    If I try to ping -6 an external host (e.g., google.com) from the client, it's able to look up the ipv6 address over ipv4, but it can't ping.

    I'm assuming the problem is being caused by there being no route for prefix+1/64 on pfsense. I could see the route for prefix/64 on diagnostics / routes, so I tried to create a static route for prefix+1/64. I copy/pasted the prefix/64 route and accidentally saved it before I edited the address to +1. I edited the route to prefix+1, saved it and now the original prefix/64 route is gone from diagnostics / routes. I tried to create a static route for prefix/64, but it doesn't appear in diagnostics / routes and it also doesn't work. There is no ipv6 connectivity. How do I get my original prefix/64 route back and how do I create a prefix+1/64 route for openvpn?



  • I deleted the static route that wasn't doing anything, then rebooted pfsense. The original prefix/64 route came back.

    What's the proper way to create a route for prefix+1/64?



  • If anyone has any suggestions about this, I'd really appreciate it. Aside from it being a routing issue, I'm out of ideas as to why the server works for ipv4, but not for ipv6. I can post the existing routing on the client and/or server pcs and pfsense if that would help.


Log in to reply