PfSense na proxmox



  • Część, mam problem z poprawną konfiguracją pfsens zainstalowanego w wirtualce proxmox'a.

    Serwer na którym to wszystko stoi jest wykupiony w hetzner.de i posiada jedną kartę sieciową.
    Mam 2 adresy ip i chce zeby jeden był przypisany bezpośrednio do proxmoxa a 2 do pfsense.

    148.x.x.50 -  ip główne dla proxmoxa
    136.x.x.85 - ip dodatkowe dla pfsense

    Z poziomu proxmoxa jest dostęp do internetu jak i do pfsense. Z poziomu pfsense jest dostęp do proxmoxa al nie ma do internetu.

    Moja konfiguracja wygląda następująco:

    
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet static
        address     148.x.x.50
        broadcast   148.x.x.63
        netmask     255.255.255.224
        gateway     148.x.x.33
        pointopoint 148.x.x.33
    
    #    up route add -net 148.x.x.32 netmask 255.255.255.224 gw 148.x.x.33 eth0
    
    auto vmbr0
    iface vmbr0 inet static
        address     148.x.x.50
        netmask     255.255.255.0
        bridge_ports none
        bridge_stp  off
        bridge_fd   0
    
        up ip route add 136.x.x.85/32 dev vmbr0
    
    auto vmbr1
    iface vmbr1 inet static
        address     10.0.0.254
        netmask     255.255.255.0
        gateway     10.0.0.1
        bridge_ports none
        bridge_stp  off
        bridge_fd   0
    
    auto vmbr2
    
    iface vmbr2 inet manual
        bridge_ports none
        bridge_stp  off
        bridge_fd   0
    
    iface eth0 inet6 static
        address     
    
    <main ipv6="">
        netmask     64
        gateway     fe80::1
    
    Czy ktoś jest w stanie mi pomoc z tym problemem.</main>
    
    


  • Musisz poszukać na forum proxmox -  najprawdopodobniej masz problem routingiem w proxmox. Sprawdź konfigurację w proxmox .
    to może pomóc https://forum.proxmox.com/threads/multiple-public-ip-help-plz.13832/