OpenVPN can connect and ping but can't access



  • I have configured openvpn server on my pfsense 2.3 and openvpn client on my ubuntu I can connect and ping all my virtual machines in the local network but I can't ssh or access to any one of the VM's (I can't access to any web app). I also tried to connect with another machine (windows) I get the same result.

    please help me I have spent  a long time trying to solve this issue but  didn't reach any result.

    bellow some screenshots maybe help us to find a solution

    OpenVpn server configuration:

    [imghttp://i86.photobucket.com/albums/k87/nasriashref/2_zpsjwo0bez8.png?t=1475746208[/img]http://

    WAN rules:

    LAN rules:

    OpenVpn rules:

    NAT :

    Ifconfig result:



  • I'm no expert, but I see one thing.

    Force all client traffic creates a safe browsing VPN that makes your IP look like you're browsing from home.

    Uncheck that box and a few other boxes open up below. One asks for the IPV4 subnet for the main network. Enter one, clear your pc cache, and try again. This worked for me in a similar situation. I got remote desktop to connect.



  • I did not get what should I do exactly, may you be more clear and explain what I have to change and what I have to add ?
    thanks


  • LAYER 8 Netgate

    With redirect gateway you do not have to push those routes. If you only want to route certain networks from the client over the VPN then uncheck redirect gateway and you will be able to enter those networks there. Again, you don't need to mess with those push route entries in that case.

    You have wide-open rules on OpenVPN so it is not that.

    You can ping so the routing is fine.

    This will probably end up being something on the servers preventing the connections from the 192.168.2.0/24 network on those services.

    Capture traffic on pfSense LAN looking for the TCP SYNs going to the servers and nothing coming back. That will point you directly at the server configuration.


Log in to reply