SOLVED: NAT / Rules (port forwarding) Issue



  • I have the SG-2220 with the latest firmware (2.3.2). I have a Synology NAS running OwnCloud that works perfectly on my intranet, however I'm unable to connect to it externally. I have assigned port 81 (http) and 4331 (https) on the NAS and OwnCloud; again this works on the Intranet. When I attempt to connect remotely however via DDNS, I cannot connect. If I connect to XXX.XXX.XXX.XXX without a port, it does hit my SG-2220 as I get the pfSense error message that states:

    Potential DNS Rebind attack detected, see http://en.wikipedia.org/wiki/DNS_rebinding
    Try accessing the router by IP address instead of by hostname.

    However, when I go to xxx.xxx.xxx.xxx:81 (or :4331) I get "This site can’t be reached"; I have used both Safari and Chrome with the same results.

    I assume it's something wrong with my port forwarding rules, however I had this working before so I have no clue.

    A slightly different topic and this could be relevant. Last week I had a DHCP reservation that was not taking. I backed-up my config, went to factory defaults, and then did a restore of the config. Once I did this the DHCP reservation begin to work.

    Any help would be greatly appreciated.
    ![Screen Shot 2016-10-07 at 10.28.53 AM.png](/public/imported_attachments/1/Screen Shot 2016-10-07 at 10.28.53 AM.png)
    ![Screen Shot 2016-10-07 at 10.28.53 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-07 at 10.28.53 AM.png_thumb)
    ![Screen Shot 2016-10-07 at 10.29.05 AM.png](/public/imported_attachments/1/Screen Shot 2016-10-07 at 10.29.05 AM.png)
    ![Screen Shot 2016-10-07 at 10.29.05 AM.png_thumb](/public/imported_attachments/1/Screen Shot 2016-10-07 at 10.29.05 AM.png_thumb)



  • Your rules look ok to me.  It must be something else.



  • SOLVED.

    I was attempting to connect to the DDNS address from my intranet (192.168.x.x) address which was causing the issue. As soon as I used a VPN or went to the local coffee shop it worked.


Log in to reply