VPN client access is blocked while connected to VPN server



  • I have a freenas machine with a transmission jail that connects to airvpn. At home I have no problem accessing it and has full Internet connectivity. However, when I connect to my pfsense openvpn server I can access everything on my lan but not my transmission jail. I thought I might be PFBlockerNG but have disabled and it still won't work. Still pretty new to PFsense and firewalling in general.



  • Anyone? If you have questions about the setup I can go into more detail…



  • Maybe the jail blocks access from unknown subnets like your VPN IP. If that's the issue you can solve it by doing outbound NAT at pfSense.



  • I thought that may be part of the answer. I had someone else on reddit run me through trying to setup static routes and it didn't work. So I'll look into outbound NAT. Any tips?



  • Add a rule:
    interface: LAN (or which one your NAS is connected to)
    source: VPN tunnel subnet
    dest: NAS jail
    translation: interface address

    Your outound NAT has to be set to hybrid or manual rule generation.





  • @viragomann:

    Add a rule:
    interface: LAN (or which one your NAS is connected to)
    source: VPN tunnel subnet
    dest: NAS jail
    translation: interface address

    Your outound NAT has to be set to hybrid or manual rule generation.

    That didn't seem to do it. I tried adding in the IP to the jail in the destination field, but it kept changing the IP to .0 instead of .2 at the end. Tried a few variations too, still no luck.



  • @tstorm:

    but it kept changing the IP to .0 instead of .2 at the end.

    Have you set the mask to /32?

    You may also try any here.



  • Good call I'll try that soon.



  • Nope, didn't work. I already have a outbound rule that has my VPN subnet set to any dest. I can access everything else on my network, just not this jail and only when connected to vpn.


Log in to reply