Captive portal - Redirection Client Issues, Android



  • Running 2.2.6 and having issues with mainly android devices, it appears to work for browsers but the newer androids intercept and open the page via some other browser.  I am running with no authentication, they only have to agree to the terms and it's supposed to re-direct to the original page they were trying to bring up.

    On the android phones, when they connect it opens a the page but never re-directs when you select agree.  I have the option to capture the MAC address so they only have to do this once and when you hit the agree in android it is adding the mac address to the list but it never leaves the page its on. Actually it adds the mac address each time you hit the button, I can have a mac show up 10 times but it stays on the same page since you didn't open a page trying to go anywhere like you would in a browser, how do I trick it into completing.

    I need some help trying to figure out what my options are for redirection, I understand that its a client issue and I probably cant solve them all but trying to cover most of them.

    Here is my redirect code:

    I've searched and found some suggestions but so far nothing is working for me. I'm working on getting android working first and then go from there.

    Any suggestions would be welcome. :)

    Thanks



  • @bishoptf:

    Running 2.2.6 and having issues with ….

    What about leaving this old version, and upgrade ?

    I didn't heard about android users complaining that 2.3.2 isn't working well for them.

    Take note : who remembers issues and bugs present in 2.2.6 ?



  • @Gertjan:

    @bishoptf:

    Running 2.2.6 and having issues with ….

    What about leaving this old version, and upgrade ?

    I didn't heard about android users complaining that 2.3.2 isn't working well for them.

    Take note : who remembers issues and bugs present in 2.2.6 ?

    Yeah understand, it's in the plan and will be taking place hopefully shortly but was hoping to tweak and keep things working.  I finally had to turn the portal off and just leave it running without the TOS, its not working for anything including PC browser.  Source looks correct with a URL in the redirect value but nothing I tried got it working.  It redirects to the portal page and when you select continue it just reloads the portal page and adds your MAC address to the passthrough list but thats about it, each time you do your MAC address gets added to the list.

    Hopefully I can get it working when I upgrade, I have new hardware so I will be able to test it and make sure its working before going live.