OpenVPN über den pfBlocker leiten?



  • Hi,
    Wenn ich mich via VPN auf die pfSence einlogge scheint der Traffic nicht über den pfBlocker zu laufen. Wie kann ich das ändern?



  • Hallo,

    dazu musst du dem VPN-Server erst ein Interface zuweisen. Interfaces > assign > unter Network Ports den VPN-Server auswählen und auf Add klicken. Dann auf das neue Interface klicken und es aktiveren und ihm einen Namen Belieben geben.
    Anschließend muss du auf diesem Interface die benötigten Firewall-Regeln setzen oder vom VPN-Interface verschieben.
    Danach sollte das Interface in der pfBlocker Konfig zur Auswahl aufscheinen.

    Mach das aber nicht über VPN, denn solange die Regeln nicht gesetzt sind, hast du keinen Zugriff!



  • Hallo.
    Danke für deine Antwort. Klappt leider noch nicht.
    Also VPN + Rules steht bereits.
    Habe das VPN als Interface hinterlegt und aktiviert. Mehr muss ich da nicht winstellen, oder?
    Dann habe ich bei pfBlocker das Interface ausgewählt.
    Funktioniert aber nicht.



  • Hast du es zu den Outbound Interfaces hinzugefügt und deine pfBlocker-Regeln auch für Outbound-Filterung eingestellt?
    Dann solltest du auf dem VPN-Interface die pfBlocker-Regeln angezeigt bekommen. Ist das der Fall?

    Ich habe eben bemerkt, dass pfBlockerNG das auch ohne manuelles Anlegen eines Interface kann. Es gibt dafür unterhalb der Interfaces-Auswahl eine Option.



  • Danke. Die funktion habe ich auch wntdeckt. Ist jedoch nutzlos.  :o