Settings in SquidGuard



  • Hello All!

    Just a comment to post here after a frustrating evening undoing a setting in SquarGuard:
    On the Common ACL tab, there is a great feature called "Do not allow IP-Addresses in URL "
    When you check that, you cannot go to any web address by it's IP address.

    I did find that this does not block an :8080 / :443 / or any other port that is not 80.  So If I go to 1.2.3.4, I'm blocked
    If I try 1.2.3.4:80, I'm blocked.  If I go to 1.2.3.4:8080 or 1.2.3.4:443 I have access.

    If anyone can tell me how to add these ports ONLY with the activation of the "Do not allow IP-Addresses in URL " switch, I'd appreciate it.

    The other this is, the only way I can truly "uncheck" this feature is not just to save the setting, but I have to reboot PfSense.  Once it physically reboots, then the setting for this sticks.

    I'm not complaining about the reboot, I'm just reporting I did not see this step in any docs.  Would have saved me several hours if I had seen it somewhere.



  • No idea.  Post your issue in the Proxy/Cache forum and perhaps someone will see it.



  • i see this behavior too.
    settings on the squidguard pages get active only after a complete reboot.
    service stop/start does not help.

    on saving squidguard config from gui - the settings get written to /cf/conf/config.xml
    the file /user/local/etc/squid(guard)/squidguard.conf stays the same.

    after an reboot squidguard.conf contains the new settings



  • For squidguard settings, you must click both the Save button on the tab you're working with, and then the Apply button at the top of the General Settings tab.