Captive portal letting me down…...



  • Ok, here is the story. I manage a large network with remote locations and about 10 pfsense servers. They all use captive portal and it works with our Radius/ldap central server. This morning I was installing a new one at one of the sites. This server has 4 opt interfaces /vlans, one of them is for wireless access and is used with captive portal.
    Now, I am able to browse the web, in each one of the four vlans. When I enable captive portal and ask it to use the wireless network. Nothing changes…in fact I tried all four different vlans with captive portal and I was never asked for credentials. I tried this from different computers  and after rebooting everything several times.

    lan = 192.168.0.0/24
    wireless = 192.168.40.0/24

    One more thing, from any vlan, if I try opening 192.168.40.1:8001 I get a blank page, but if I try opening 192.168.0.1:8001 I get CP page. I also checked the firewall logs and nothing is being blocked...
    I have compared this new servers conf file for the CP section and everything looks normal.
    I am out of ideas, Please help!.
    eric.



  • Captive portal does not bind to the WAN interface so it should not load from the WAN IP. Tonight I helped some with a captive portal problem where the captive portal was not blocking anything. In his case captive portal was assigned to opt1 and there was a problem that was caused by a bad rule on the optional interface. In your case captive portal is assigned to the LAN so you should take a look first at the rules assigned to the LAN. If you still can't resolve the problem post a screen shot of your LAN rules. One way to find out is to disable the rule and then test captive portal.

    Hope this helps.


Log in to reply