Firewall Rule not using correct gateway



  • Hi guys, I'm having this really frustrating issue since I've upgraded. I have a working OpenVPN setup but the issue is I only want it for certain IPs. The solution was simple, create a rule that would direct those IPs (represented by an alias) to use the VPN and everything else use the WAN. However, since I upgraded to 2.3.2 it's like the rule is being ignored.

    Ultimately, everything is going out the VPN including what's in the alias there seems to be no stopping it unless I disable the VPN then everything is on the WAN including everything under the alias which should also not happen. Am I missing something? Thanks!




  • Netgate

    Do you have Don't Pull Routes checked in your OpenVPN client config? If not, check it and try it again.