PROBLEMAS con openVPN, me conecto pero no puedo accesar a equipos en LAN.



  • Hola!

    Tengo un problema al configurar openVPN, NO puedo accesar a los equipos que están dentro de la LAN:

    Realice unas configuraciones de openVPN y para eso me guié de la siguiente documentación, aquí el link: http://www.3ops.com/implementacion-de-vpn-cliente-servidor-con-openvpn-y-pfsense/
    Al realizar mi conexión desde un equipo conectado a Internet me logra dar una IP de la LAN: 10.10.0.6, inclusive me parece la conexión lograda en el status de openVPN

    Esta es mi configuración de las redes para realizar el túnel:

    También realice la configuración de reglas en la WAN y el openVPN en el Firewall:


    Espero su AYUDA!
    Muchas Gracias!!
    Saludos!!



  • ¿Los equipos en LAN tienen como puerta por defecto la LAN de pfSense?

    Si no es así, tienes un problema de enrutamiento.



  • hola bellera gracias

    Si todos los equipos dentro de la LAN en este caso tengo servidores y tiene como puerta de enlace la 10.10.10.8 que es la IP de mi servidor PFSENSE.
    Al consultar la IP que me da cuando hago la conexión he notado que no me da una puerta de enlace, ese puede ser el problema?



  • cuando hago la conexión he notado que no me da una puerta de enlace, ese puede ser el problema?

    No. Eso va por rutas.

    Entiendo que estás con un Windows. Si no recuerdo mal,

    route PRINT

    http://www.computerhope.com/routehlp.htm

    Sobre IPs y máscaras OpenVPN, https://forum.pfsense.org/index.php/topic,63552



  • Comprueba que tienes activada una opción de permitir que los clientes se vean entre sí:

    También comprueba como te dice el compañero que las rutas están correctas. Deberían aparecerte varias rutas relacionadas con tu VPN y una de ellas debería ser a la red de la VPN (10.10.0.0 - 255.255.255.0). También si quieres acceder a redes distintas a la de la VPN necesitas indicarlo en la configuración del OpenVPN para que cree las rutas en el equipo cliente al conectar.

    El mío por ejemplo crea estas:

    Ahí puedes ver dos rutas a la red VPN, y otras dos a redes aparte. Eso es linux, pero en Windows sería prácticamente igual.

    Un saludo.



  • ya cheque mi tabla de ruteo y es la siguiente:

    De igual forma ya tengo marcada la casilla y sigo con el mismo detalle no puedo accesar:

    No se si tengo la configuración correcta en client settings:



  • Perdona, pero no entiendo qué está en cada lado.

    Por favor, topología. Parece como que…

    Lado Servidor OpenVPN
    LAN 192.168.1.0/24
    pfSense como puerta de enlace en 192.168.1.254/24
    Red para OpenVPN, 10.10.0.0/20
    Red local a acceder, 192.168.1.0/24 (puede dejarse en blanco)
    No necesitas marcar que los clientes se vean entre ellos (inter-client communication)

    Lado cliente
    No sé que rango estás empleando ni puerta en la interfase física "normal", que es la que enruta el tráfico.
    ¿ Quizás 192.168.1.75/24 con puerta 192.168.1.254/24 ? No deberías usar la subred 192.168.1.0/24 en los clientes remotos.

    Reglas OpenVPN
    La segunda regla que tienes ahí no sirve para nada, pues la primera deja pasar todo.



  • Este seria mi escenario



  • Pues entonces no tienes bien la configuración. Tendría que ser algo como:

    Lado Servidor OpenVPN
    LAN 10.10.10.0/20 (es decir, 10.10.0.0 - 10.10.15.255)
    pfSense como puerta de enlace en 10.10.8/20
    Red para OpenVPN, 192.168.100.0/24 (cada cliente remoto precisa 4 IPs)
    Red local a acceder, 10.10.10.0/20 (puede dejarse en blanco)
    No necesitas marcar que los clientes se vean entre ellos (inter-client communication)

    Lado cliente
    192.168.1.75/24 con puerta 192.168.1.254/24



  • https://forum.pfsense.org/index.php/topic,63552

    Para clientes remotos (road warrior):

    • 192.168.XXX.0 -> Subred servidor

    • 192.168.XXX.1 -> Servidor OpenVPN (pfSense)

    • 192.168.XXX.2 -> Puerta para el servidor OpenVPN (pfSense)

    • 192.168.XXX.3 -> Broadcast servidor

    • 192.168.XXX.4 -> Subred primer cliente

    • 192.168.XXX.5 -> Puerta para el primer cliente remoto

    • 192.168.XXX.6 -> Primer cliente remoto

    • 192.168.XXX.7 -> Broadcast primer cliente

    • 192.168.XXX.8 -> Subred segundo cliente

    • 192.168.XXX.9 -> Puerta para el segundo cliente remoto

    • 192.168.XXX.10 -> Segundo cliente remoto

    • 192.168.XXX.11 -> Broadcast segundo cliente



  • GRACIAS Bellera!
    Me ha sido de mucha utilidad la información!


Log in to reply