Firewall blocking uploads on certain sites



  • Hello,

    Im having some problems at my home with pfsense. i tried to upload some images to imgur and i fail every time. I looked into the logs and i see this:

     X	Oct 26 01:50:05 	WAN 	192.168.11.1:33596 	239.255.255.250:1900 	UDP [many copies of this line]
     X	Oct 26 01:50:27 	WAN 	212.96.201.120:39877 	192.168.11.2:23 	TCP:S
    
    

    My network atm is WAN -> 192.168.11.x [modem] -> PFSENSE -> 192.168.8.x

    Any clue or setting i should modify to allow this upload? It works normal from 192.168.11.x network.

    Regards ~



  • Its happening also on Amazon site that takes forever to load and some other sites where i cannot really upload.

    The same sites worked before installing PFSENSE



  • I very much doubt that pfSense is stopping you from uploading images.  Those two specific lines from your firewall log show blocks on WAN from unsolicited incoming traffic.  The first line looks like a uPnP block, and the second is someone trying to look for a telnet server.  Neither have anything to do with your problem.  Can you upload images here via the Attachments and other options feature?



  • I tried to disable Kaspersky and nothing. I tried to upload an attachment and fails, go on with Sending request forever and no network activity on the computer.

    Also, my Gmail attachments doesnt upload anymore  :-\

    The same thing happened in another place where i installed pfsense, there a windows pc was trying to upload some radiograph photos to a site that provide a sort of DB service and failed. I moved the photos on a Mac that they use there and the photos uploaded just fine.
    Maybe is some strange behavior with NIC drivers or Windows doing strange things?

    I can try to upload on the same site from there to see if is the same problem.

    Will post all the firewall log be a help?
    I dont care for privacy, the ip is dynamic after all  :P

    I tried to modify many options but none worked (and i put them back how they was)


  • Rebel Alliance



  • Maybe is some strange behavior with NIC drivers or Windows doing strange things?

    If it works for a different client on LAN then I would say yes, the problem is with your Windows box for whatever reason.



  • @ptt:

    ??? maybe –> https://doc.pfsense.org/index.php/Low_Throughput_Troubleshooting#MTU_Issues

    Tried with different MTUs, no difference.

    And for the different machine i guess it was a strike of luck because i just tried with another mac and does not work.
    The i switched network plugging the ethernet in the modem/router and works, same machines.

    Its really pfsense that is doing something but i do not know what.

    ATM pfsense is virtualized in KVM, maybe is that the issue? But it will be strange because it has support for it….

    EDIT: ok, i got this: https://forum.pfsense.org/index.php?topic=88467.0
    I had to set tx off in br2 and br3 ( LAN and WAN bridged for pfsense vm) and seems to do the trick...

    OT: Seems true that the moment you ask for support you start to realize things...  :P

    Thank you for the answers!


Log in to reply