Memory error reloading pfB_Top_v6 (SOLVED)



  • running

    2.3.2-RELEASE-p1 (i386)
    built on Tue Sep 27 12:13:32 CDT 2016
    FreeBSD 10.3-RELEASE-p9

    AMD Athlon™ 64 X2 Dual Core Processor 3800+
    2 CPUs: 1 package(s) x 2 core(s)

    Not sure why I would get memory error when free memory is showing 50% of 1gb

    error message:

    There were error(s) loading the rules: /tmp/rules.debug:26: cannot define table pfB_Top_v6: Cannot allocate memory - The line in question reads [26]: table <pfB_Top_v6> persist file "/var/db/aliastables/pfB_Top_v6.txt" @ 2016-10-26 08:52:05



  • Just some more FYI,

    If I do not chose any of the geoip top20 ipv6 countries, I do not get the error message.



  • You need to raise Firewall Maximum Table Entries in System / Advanced / Firewall & NAT.



  • Thanks Ron,

    Worked fine. you would like it should spit out an error message like "maximum entries reached" and not a memory error ::)



  • It's not pfBlockerNG that generate the error, it's the reload process.

    Default settings in pfSense can not handle huge alias table like GeoIP IPv6 tables.


Log in to reply